Webcam not being detected by lsmod anymore

I have a Quickcam 9000 on a friends computer running Suse 11.0. Originally it detected the camera in LSMOD, however the picture was distorted and garbled.

I assumed it was the drivers and proceeded to install the drivers at Linux UVC driver & tools and also the driver qc-usb, and I might have tried the drivers at http://mxhaard.free.fr/spca5xx.html as well. One after the other because none worked. Now its at the point where it cant even detect the camera, or one that I found to be compatable with other Suse 11 computers (quickcam messenger).

Why cant it detect ANY camera now? I’m coming from the Microsoft side and I’m struggling lots with understanding drivers. (I tried looking for some higher level guides of lsmod/modprobe/modules in general but I cant for the life me find ANYTHING high level about the driver system in general).

any direction would be appreciated.

do you know how to open a terminal?

if you do, type in the command

lsusb

and post back to the forum what it says;

this might help identify the camera by product and ID number

(Sounds as though it is likely to say

ID 046d:0990 Logitech, Inc.

http://blog.gnist.org/article.php?story=Linux_and_LogitechQuickCamPro9000

see if the above posting is any use to you: talks through the install of this webcam, assuming yours is the same

sorry i meant lsusb, no it is no longer detected, as well as my other camera which is compatable and works with systems I didn’t mess around with.