Webcam elianzo driver

I have a new webcam HD Elianzo.
Works perfect out of the box only I have low resolution 640x640 so I need support.
Is there a driver for linux ?

If it is working at all in Linux environment, you have driver support. :wink:

To find the driver, look for the relevant output form the following command…

usb-devices

It will list all connected USB hardware, one block will pertain to the webcam device.

Yes i see a list usb-devices
The problem is not that the webcam not worked but is shows only low resolution 640x640

Your first question was whether a Linux driver existed. The output from the command I gave you will tell you exactly which driver is loaded. I expected that you would post the relevant section including the chipset details. Then others might be able to advise further.

This may be of value to you

https://wiki.archlinux.org/index.php/webcam_setup#Command_Line

A wiki page that has some practical info concerning v4l2-ctl and should be applicable to your hardware

http://trac.gateworks.com/wiki/linux/v4l2

Vendor =1b3f General Webcam

Try guvcview to see if there is a higher resolution.

Which program need a higher resolution?

OBS studio for making 3d tutorials.

That not enough IMHO. typically one should provide xxxx:yyyy but you only provided the xxxx (vendor) but not the yyyy (product).

I don’t see that vendor ( 1b3f ) listed in the UVC listing of supported webcams: https://www.ideasonboard.org/uvc/ … but that could be an out of date list.

The UVC FAQ gives excellent information for troubleshooting webcams - prior to going to the UVC list for help.

I see no vendor name :

lsusb
Bus 002 Device 004: ID 046a:0023 Cherry GmbH CyMotion Master Linux Keyboard G230
Bus 002 Device 005: ID 1b3f:2247 Generalplus Technology Inc. 
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Solved the problem could now change the resolution with webcamoid.

Anton, thanks for sharing your solution.

I do note that that information was what we needed to help - but I see now you have solved which is great.

For anyone else watching this thread, here is a problem solving technique. I used the (late provided) info from ‘anton’ and I did a google search using as a search criteria: " Generalplus Technology Inc. webcam 1b3f:2247 "

That gave me a number of hits, but one at the top of the google list was this: https://raymii.org/s/tutorials/Get_webcam_resolution_and_info_on_Ubuntu_and_fix_HD.html

Date of post: : 23-08-2020

It refers to that same web cam, describing the same problem , and gives that fix.