web site doesn't show flash in Firefox

I use Firefox 35.0.
in my browser Flash-player works well in many web sites.
But, in this web site http://www.bl.uk/learning/langlit/sounds/index.html


Firefox’s flash-player doesn’t show flash animation, sounds. (It should show a Great Britain map with all British accents instead of black space).

I Tried open this site in Chrome - it works.
But in Chromium and Firefox - don’t.

How can I fix this bug?
Does it work in your Firefox browser?

tanks to adobe Firefox uses an old flash v11.
you can try and use chrome’s flash 16 with freshplayerplugin from packman

sudo zypper in freshplayerplugin

you need packman’s repo enabled

Does it work in your Firefox browser?

… nope. Just a black square, as you said, although a right click gives access to the Flash properties and so forth.

it works (for me) with freshplayerplugin and pepper-flash

ps. chrome uses a local flash player, to get it to work with chromioum you need pepper-flash, to get it to work with firefox you need pepper-flash and freshplayerplugin
for Chromium install chromium-pepper-flash

sudo zypper in chromium-pepper-flash

for Firefox install freshplayerplugin and chromium-pepper-flash

sudo zypper in freshplayerplugin chromium-pepper-flash

I’m not 100% sure it works with FF, I can navigate the flash elements and listen to the audio clips but I didn’t see a map, I don’t have chrome or chromium to compare.

I’ve installed freshplayerplugin and chromium-pepper-flash. Flash-player have been upgraded to new version
But there is no animation, sound. There is still black space in the page.

It works in Chromium, but not in Firefox browser.


As you see the flash map of Great Britain instead a black square.

It works fine in Konqueror and rekonq as well, with the standard 11.2 flash-player (I don’t have chromium-pepper-flash nor freshplayerplugin installed):
But it doesn’t work here in Firefox either.
So this seems to be a problem in Firefox (or the page), not flash-player.

PS: it actually seems to be a bug in the page. It doesn’t work either if I tell Konqueror to spoof itself as Firefox or Netscape, but it works fine if Konqueror identifies itself as Konqueror (or Internet Explorer, Chrome, Opera, Safari, …)

Thank you for sharing.
Yes, perhaps this is a problem in Firefox browser.

No, it’s a problem with the page or rather the particular flash content as mentioned.
If I tell Konqueror to identify itself as Firefox, the same problem occurs.

Maybe they don’t want that their visitors use Firefox? lol!

Perhaps you’re right​:+1::grinning:

yes that’s what got me a bit confused, I was messing around with prefbar (a firefox addon) and one time it worked a 2nd time it did not, here’s a screenshot from windows one is regular firefox the other is firefox identifying as chrome, the 1st does not work the 2nd works


there is a bug in the website, strangely enough ie10 doesn’t work too,

it’s a strange website that only works with 1 browser.
How to fix it in Firefox well you can change the browser id via about:config or use prefbar
or use a 3rd party addon like User Agent Switcher

Thank you for help.
It works in Chromium after installed chromium-pepper-flash.

I tried to use prefbar and it works with this browser id: IE 9.0 Win7, Chrome, Safari, Linx.

That’s very interesting - it doesn’t work only with Firefox :):):slight_smile:
The website architector perhaps don’t like Firefox:)