Web connect

I have made about 4 or 5, 12 hour sessions in the last 6 months in an attempt to use Linux. The nearest I got was with Ubuntu. I connect to the web via a USB (advent) bluetooth dongle and my mobile phone. I saw an article in LF saying how easy it was to connect a mobile, prior to this I have SUDO Bashed all over the place to no avail.

On SUSE, I plug in the dongle with no recognition, obviously pairing is out of the question and what do I do next to connect to the Web. Pan is not recognizes by Linux only DUN which doesn’t exist on the Active Sync.

Help please, I need to escape from windows into Myth TV.

I have an AMD 64 bit system with 2G of RAM, obviously no internal bluetooth and a twin DVB Happauge TV card and an HTC touch HD phone. No land line

You have to sort out 2 issues here:
(1) Make the bluetooth work on your machine so that you can see your phone from your machine via bluetooth
(2) Connect to the net via the phone using Bluetooth’s DUN.

All commands below must be run as root.

Let us solve one by one. Have you installed the bluez package? If not, go to the yast and install it.

Run the following and see if it showing the “running” status.

rcbluetooth status

If not, run it.

rcbluetooth start

Once, it is done. See if you can see your bluetooth device or not.


Yous should see something like below:

hci0:   Type: USB
        BD Address: 00:21:E9:D7:1F:B3 ACL MTU: 1021:5 SCO MTU: 64:1
        UP RUNNING
        RX bytes:832 acl:0 sco:0 events:45 errors:0
        TX bytes:2606 acl:0 sco:0 commands:45 errors:0

Once you are here, run the following command to find your mobile device (enable bluetooth on the mobile before this).

hcitool scan

If you can see your mobile listed in the output, then you are done with the first step.

Thanks ever so much for your help.

However, after kbluetooth never responded to being pressed. Bluez was ticked as a packet but needed to be downloaded to update; the PPP package was a mystery, any commands I gave got refused asking me for my password and not responding to its input. Thoroughly frustrated I partitioned over it, formatted and loaded Ubuntu, so far I have paired it, with Bluetooth as well and I am working to get the modem recognised by Linux. Spent most of the week trying to use Linux. If I ever get on the net I’ll switch over. Linux reminds me of the days I used to play with DOS commands, before GUI’s. I have another 30 years before I kick the bucket, should do it by then. I recognize most of your reply, in Ubuntu my commands are accepted. Swears at me when I input ‘gedit’ though.

Thanks again


In my instructions, I didn’t ask you to type kbluetooth or ppp. I mentioned there are 2 issues here and I wanted to know if the first issue is successfully resolved or not so that I can help on resolving the 2nd part.

Now, if you have already loaded Ubuntu, then, there is no point in wasting my time by typing up the rest now.