web-cam problem

i am using opensuse 11,2 version, i have a webcam that name is Logitech Quickcam Express.i started cheese webcam application but it doesnt capture my webcam, than i installed webcam drivers from software-manager. and restarted system but cheese doenst capture my webcam. i looked at the hardware manager, my webcam shows at under usb and it has driver information under category,

what should i do ?

thanx regards,

Did you try with any other program? Kopete?

hmm i didnt hear it before, i am new at linux.
thanks i will try it.

If you are running KDE, Kopete must be already installed.

no, i am using gnome desktop. thanks kopete captures my webcam :slight_smile:

If kopete can capture but cheese not.
You may try to update your gstreamer-0_10-plugins-good from openSUSE-Update

hmm i will try thanx :slight_smile:

Oh I have has issues with cheese in the past, but the solution for you might be simple…
Try attaching your camera to another USB port, if this is a desktop then may I suggest using the ports on the back if you have them.
Thats how I got my webcam to work, same brand and model here works fine for me so this is not a linux issue per say…
Might be an app issue but you have not mentioned your specs yet so that is something to consider.
You probably did like I did, pop the webcam in the front ports for easy access. Even if this is a laptop who knows, my solution might just work.

hmm thanks you, too.

Tell me if that works, if it doesnt there is more then one way to get a webcam to work, but can you give us your specs anyhow?
It doesnt hurt to le us know your computer model, computer type and any hardware/ software info…
Like what version of openSUSE did you install, I know its 11.2 but you didnt say if this is KDE, Gnone, x86 or 64bit.
Info like that can be helpful to us.

ok my pc is a x86 desktop and i am using gnome desktop, its to easy to use for me. my webcam is Logitech Quickcam Express. my cpu is intel 2x2.40ghz and 2gb ram. is it enough ? is there any way to use cheese in practical way ? i mean, “install this package and it will solve your problem”

Yeh thats good enough, trust me giving us your hardware info does help in solving issues.
Anyhow cheese for me never worked that great in openSUSE, even when I moved it to another USB port it still doesnt work too well… well for me at least, your experience might be different, but we will see before we try anything drastic.
I still suggest installing wxcam, if popping the webcam in another port doesnt work.
It seems to detect the webcam better, there is no native installer for it though for openSUSE but I do have a package for you and instructions on how to install it but we will see if moving the webcam to another USB port works or not first…
One step at a time here.

“gstreamer-0_10-plugins-good” doesnt enough to work cheese with my web-cam. thanx at all.

Well it was worth a shot, did you try my suggestion yet?
By the way you may want to try more then one US port and also close cheese each time you try a new USB port…
Cheese gave me a USB port chase, one out of my six USB ports and it worked.
Cheese is terrible on openSUSE I swear.
Works great on Ubuntu, and mandriva but not on openSUSE in my experience.

i will try now

i didnt find wxcam in software-manager ?

skype doesnt support webcam too ?

Its not in the openSUSE repos, not even in the third party repos.
I will give you the package then but please follow my tutorial as following:
First download my package:
Secondly, dont install it right away… it wont work as openSUSE has trouble installing most third party packages IE .rpms you get from the net, in openSUSE .rpm is sort of like .exe in windows but the openSUSE software installer is rather tetchy… its one of my gripes about the distro.
To make sure this installs firstly I suggest you create a new folder inside of your downloads folder and call it RPMS.
Creating a new folder in openSUSE is simular to creating a folder in windows, it should be easy to do for you.
Keep in mind that this file will probably either download to your home directory, or sometimes your download (pr downloads in my case) folder… this varies per setup but make sure to check both your home and download directories.
In any case put my RPM in this new RPM folder.
Now here is where it gets a little tricky:
open up YAST, if you dont know what YAST is or located just say so and I can help you there.
Now in YAST go to software repositories
open that up and let the repository loader run, it takes a bit sometimes.
Once that is open use the “add” butto and click on the checkbox that says “local directory” next to it.
after that it will ask where you want to link this to, go to the “browse” button and make your way to your newly created RPMS file…
This part might be tricky to navigate, the directory manager here is a little rough to deal with, just go to /home/*your name here/download/RPMS as I suggested.
after that hit the “ok” button once you find your way.
For the name I suggest calling it My RPM’s, thats how i set mine up
click on next and dont worry about the “plain rpm” nonsense thing
and this should be done.
once thats over load the package manager, search for wxcam and install.
This is a little complicated I know, its a lot to deal with for a ex windows user who is used to clicking a installer and have it magically work.
Truth be told a lot of the packages for openSUSE work this way but when loading packages not in the repo it can be a pain sometimes.
Use this method for other .rpms you might find on the net, it just sucks that openSUSE does not resolve dependencies as it should.

when i push install, it appears a msg like that
“possible libxvidcore.so.4 needed by wxca…” and there to choice break or continue ?

I said dont install it directly, follow my instructions above… dont just downlaod and install it, it wont work right off the bat.
But this issue might have something bigger, I think the main repository is down or something as my package loader is frozen.
Dont do anything just yet actually, I know you want this working but i think something is going down here.
Dont want your issue to become more complicated as it should be.