Web Browsing Unbearably Slow

Now that my network is working I’ve been trying to do some browsing with firefox. Changing pages literally takes minutes where it used to take seconds. The network does not seem to be the problem as Speakeasy speed test maxxes out my DSl connection.

I often see CPU maxxed out at 100% when attempting to load pages. This computer surfed fine with XP and also with Ubuntu.

It’s a P4 1.7 with 768G ram. Where do I start looking?

Thanks

ratcat wrote:
> Now that my network is working I’ve been trying to do some browsing with
> firefox. Changing pages literally takes minutes where it used to take
> seconds. The network does not seem to be the problem as Speakeasy speed
> test maxxes out my DSl connection.
>
> I often see CPU maxxed out at 100% when attempting to load pages. This
> computer surfed fine with XP and also with Ubuntu.
>
> It’s a P4 1.7 with 768G ram. Where do I start looking?

Did you turn off IPV6?

  • Turn off Ipv6 globally (YaST)

  • Turn off IPv6 in Firefox

Do you have Beagle Indexer enabled in your Firefox add-ons? Disabling that and turning off IPV6 helped a lot.

I had turned indexing off. I just now turned off ipv6 in yast. Haven’t found the setting in Firefox yet.

Disabled it in Firefox too. It’s way faster now! Thanks again.

Is it time for someone to rant again about IPV6 being on by default in Opensuse?

I know that the goal is eventually to move everyone over to it, but until it happens, this is a real problem for users in the United States, where IPV4 is still by far the most common. There’s no point in making IPV6 the default in a region where the vast majority of DSL modems (just to name one example) will only do IPV4.

My vote would be for the Opensuse installer to check for IPV6 support during installation. If it doesn’t get a response, it should turn IPV6 OFF (or ask the user, with a default “no” response in the dialog).