Web browsers slow to load new pages

[FONT=arial]So I’m new to Opensuse, and so far I’m having a great time!
The only issue I’ve been struggling with is that no matter which web browser I use, it always takes long to load any website.[/FONT]
[FONT=arial]Before switching to Suse, I was using Mint and this was not an issue.
I ran an internet speed test, and everything is fine there.[/FONT]
[FONT=arial]I’m using NetworkManager since I’m connected via Wifi, and I’m on Opensuse Leap 15.[/FONT]
[FONT=arial]I’ve been searching for an answer for quite some time, with no luck so far.[/FONT]
[FONT=arial]Any idea what the problem could be?[/FONT]
[FONT=arial]Thanks in advance![/FONT]

IIRC, Ubuntu/Mint went through a period of using dnsmasq which will have provided DNS caching. That may have been what you noticed with respect to browser performance perhaps…


Thanks for your help!
So you suggest that I remove dnsmasq, or that I follow these instructions to properly configure it?

I wasn’t really suggesting anything - it was just speculation about your Mint browsing experience. However, you could implement it if you desire, or perhaps just experiment with pointing at an alternative public DNS server instead.

Sorry for the late reply, I had another problem with Leap that was more urgent.
Your guess was correct, pointing at another public dns solved the problem!

Thanks a lot!

Glad to read that changing DNS server has helped with improving your browsing experience! :slight_smile: