weather forecast plasmoid crash plasma

on my opensuse 12.3 with KDE4.10.2 the weather forecast plasmoid crash plasma desktop, and the lcd weather doesn’t works, it don’t shows nothing of the correctly set location, have you the same behaviour??

thnx, ciao, pier :slight_smile:

When I first installed openSUSE 12.3, the weather icon did have a problem. Seems like I could set it and on reboot it did not work, but after a few updates, I have not seen it do that any more. Perhaps you have not done a full online update since you installed openSUSE 12.3? Here is what I do and suggest:

To fully upgrade, I would do the following tasks for openSUSE 12.3 using KDE:

  1. Go to YaST (Enter Root Password) /** Software **/ Software Repository and specify the URL addition of the Packman Repository "Index of /suse/openSUSE_12.3/" excluding the quotes if not already done.
  2. Go to YaST (Enter Root Password) / Software / Software Management and select Options and check Allow Vendor Change.
  3. Again, still in Software Management select Package / All Packages / Update if newer version available and press the Accept button on the bottom right.

You only need to do items 1 & 2 one time each. You can performs item 3 every time you run YaST to see if updates exist, even right now.

Thank You,

I have not had it crash, but it doesn’t work.

While running opensuse 12.2 (I think that was KDE 4.8.7), the weather forecast tray applet worked very well. With 12.3 (both 4.10.00 and 4.10.2), it usually works for a while after I configure it. And then it stops updating.

I tried the LCD weather widget. It also stops updating after a while.

I have given up on both.

So the Weather icon is working for me now. At first, you could configure it to work and on the next restart, it would stop working, but it keeps working for me now on each restart. Here it is tonight:

http://paste.opensuse.org/view/download/96589811

Thank You,

baaaaad, three weekend days of rain in Texas, like here in Italy… too bad, no beach… :slight_smile:
updated everything, no improvement, no weather broadcast on linux here… only rain without know before…:slight_smile:

Weather seems to be working fine since the update to KDE 4.10.3.

tried with KDE4.10.4 “release 569” the LCD weather doesn’t works, the other doesn’t crash anymore but also doesn’t works…:slight_smile:

Give plasmoid-yawp (yet-another-weather-plasmoid) a try you might be pleasantly surprised:)

good!!, it works!!!, manythanks :slight_smile:

I also use the YAWP plasmoid in 12.3 and it works well.
I’ve had similar problems in openSUSE and/or Fedora 18 with weather plasmoids.
In some cases they are not able to reload themselves, even acting manually (for instance, when you resume the machine from a suspension state).
It’s probably a problem within plasma desktop.
Restarting plasma solves the problem:

kquitapp plasma-desktop
plasma-desktop

The problem with LCDweather is that wettercom does not give reliable info on US weather. Sometimes I have been able to force it to use NOAA and that always works but then LCD will lose the connection and try to use wettercom again. wettercom seems fine for locations in Europe but is spotty at best for US locations even if listed.

There seems to be no way to force it to use noaa data but as I said I have tricked it several time. the app worked well in 11.4 but seems to be broken since.