We are getting frustrated and somewhat discouraged

Three PC’s with Leap.
Older HP Compaq (KDE) still hangs at ‘started locale service’. Have been back to the thread I have about that and do the suggestions there again. Boots well for a day or two, the back to its hang tricks.

The Toshiba laptop(Xfce) will not shutdown cleanly about 60% of the time, and have to press the power button. Usually after a failure to stop the X server, but I do see other ‘fails’ in the shutdown text.

Needless to say my wife is not impressed, and doesn’t know if she wants it on her laptop

Third PC, the HP AiO no problems, It is not dual boot.

OK, griping done. On to trying to fix things.

Cannot opine about your startup problems because I haven’t seen, much less replicated the problem.

Shutdown problems have existed in Linux since time immemorial, and aren’t usually that much of a mystery nowadays…
Before systemd, the problem was far worse, but with systemd and the way processes are run within cgroups, there are fewer situations where an orphaned process isn’t terminated properly as a result of a shutdown command.

But althugh better, shutdowns still might not happens smoothly and generally for the same reason… an orphaned process that isn’t getting the word that a shutdown command has been issued… Or, the process is running because it’s still actively doing something, like transferring a file which if interrupted would corrupt the file. Whatever the actual reason, it’ll almost certainly be related to something you installed or configured, so that’s where you should start…

Stuff like…
You configured mount points.
You installed an app that uses a database like sqlite, mysql, postgresql, etc
You installed an app that is a frontend to an app running remotely.

Build that list of everything you’ve done.
If you can’t remember what you’ve done, one option if not too complicated is to simply re-install and then keep a good record how you’re changing the machine. If you balk at re-installing, that’s possibly a good indication you’ve made changes like what I described.

But, re-installing should be a last resort…
There should be many ways to identify what is running on your machine that is preventing shutdown…

  • Run top or one of the may top derivatives like htop to identify running processes.
  • List your mounts before shutting down. Perhaps some of them should be manually unmounted.
  • View your system log as you’re attempting a shutdown, particularly if you expect a failure
journalctl -f
  • Inspect previous bootlogs. The following displays the bootlog from the previous session
journalctl -b -1

Keep in mind what you’re looking for is anything that might not respond to a shutdown command, and then determine why it’s happening. Some things like mount points perhaps should be unmounted manually. XFCE has minimal background processes by default, but you may have modified. The User may be issuing the shutdown command without manually closing all apps.