Wayland not listed by the login manager after installing plasma5-session-wayland

After installing the package plasma5-session-wayland and restarting my machine, I do not get the option to start a Wayland Plasma session from the login manager. I’ve already asked about this on IRC as well as running a web search, and several users confirm that after installing this package KDM normally offers Wayland as a choice: The option should be called “Plasma 5 (Wayland)” or similar… however I have no such thing in my available sessions list, alongside the normal Plasma 5 or IceWM.

Maybe it is not similar enough for you to recognize.

I added that package.

Using “sddm”, I see “Plasma Session (Wayland)”.

It sort-of works, in a broken kind of way. I’m logged in, but there’s a crash report there to greet me. So I try to logout, and that gives another crash report. I ended up rebooting as the sure way of logging out (“shutdown -r now” at the command prompt after using CTRL-ALT-F1 and login as root).

I then tried with “gdm”. On “gdm” the new session shows up with the name “Plasma”. Previously there were “KDE Plasma Workspace” and “Plasma 5”. Those are still there (and still work). The newly added session is just “Plasma”. And it doesn’t work. It tries to login, then I find I am back at the login screen.

So maybe look carefully at those “kdm” menu entries, and try the one that is new.

Oh… yes: I believe the current login manager is no longer called KDM, but SDDM. I use the normal one installed by KDE, which I believe is the later. Sorry for this confusion.

But yeah, I do not get a “Plasma Session (Wayland)”. I remember seeing a simple “Plasma” which is the normal X11 session, and I think two deprecated entries which are possibly a leftover from old KDE4.

I try to run Wayland about once a month and have never had a a successful session.

I have 3 differnet Wayland desktops installed.

When I logout the log back in the screen gives me choices:
Gnome (Wayland)
Plasma (Wayland)
Weston (Wayland)

None of them work well.
Plasma (Wayland) might be the weakest. I get basically the same results as nrickert. Also, it does not like a dual screen hook up between my laptop and a desktop monitor.

Gnome (Wayland) is better but is still not close to fully functional. It 2 has a problem with dual displays. No error on log in, but it does not detect my hard wired internet connection.

I have considered loading Fedora 25 just to see if they have Gnome (Wayland) fully implemented, or maybe on the debian side the RebeccaBlackOS.


grep -i 'displaymanager=' /etc/sysconfig/displaymanager

This is really weird: If I run SDDM from the console, I see an entry saying “Plasma (Wayland)”, alongside a few other differences. However if I actually log out, the real login manager has a different list of sessions! The icon also appears in different positions between the two.


Something tells me this somehow isn’t right…

Edit that file (“/etc/sysconfig/displaymanager”) and change that line to read


That is, change the “kdm” to “sddm”. Then reboot.

If you are not comfortable with editing that file directly, then use
Yast –> System –> /etc/sysconfig editor –> Desktop –> Display Manager –> DISPLAYMANAGER

and that should allow you to change “kdm” to “sddm”.

Note: I tried switching to “lightdm”. And there, the Wayland session shows up as just “plasma”. But it doesn’t work. It looks as if only “sddm” works to start a Wayland session for Plasma 5.

Problem solved: I switched from KDM to SDDM and now have both “Plasma 5” and “Plasma (Wayland)” available. I was not aware I was still using KDM, which was the root of the issue.

If you upgraded from 13.x then you still have KDM an upgrade does not do change to setup

Yep… my original openSUSE installation is as old as 2012, back when it was called openSUSE 11.x :slight_smile: Because unlike Windows, this OS keeps itself clean and optimized… it doesn’t slow to a crawl and force you to format and reinstall every few years, so there was no need to waste time on that. However it seems I need to be more aware of what doesn’t persist throughout major upgrades, like the switch from KDM to SDDM.

I tried Plasma-Wayland after the recent QT update to 5.9. It is still buggy. But it is working a lot better than before.

Some problems:

  • “ssh-agent” is not started. This is probably easy to fix. In any case, I can work around it by starting ssh-agent in my shell startup file.
  • I cannot use kdewallet. I’m not sure, but I think it is because I am using gpg-encryption. Possibly the “pinentry” window is failing to open, so I cannot provide the key to open it.
  • Windows open in the wrong area of the screen. For example, an xterm window that should open at bottom left is opening at top left. And when I right-click on desktop (to logout), the popup window shows up at top left instead of at the mouse pointer.
  • Touchpad does not disable. I have it set to disable if a mouse is plugged in. But that isn’t working with Wayland. However the Fn key to disable touchpad does work in Wayland, so I can use that instead.

Just giving an update. I still consider it not ready for prime time. But at least there is progress.