Watching video on television

Hi, i like to activate the TV out option (composite=tulip output) from my graphics controller: radeon 9200 from ATI Technologies Inc RV280

I use openSuSE 10.3 with latest driver from one-click install link. Installation was successful although glxinfo gives:

direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

Perhaps I have no issue at all and need to install some program to enable and configure video out to my television set.

Any help is appreciated…

Pretty sure that’s not installed thought glxinfo mentioned direct rendering yes and ati instead of mesa.

Can’t really help been a while since I played with ATI.

Yes I know, installer gave output successful, but a manual check did not confirm this.
My question remains; do I really need fglrx? Mesa is doing a perfect job on my flat panel monitor.

I just want to have a clone form my desktop on my television.

Hopefully one of the guru’s can give you proper assistance but a quick google seems to imply you don’t need it [Phoronix] Open-Source ATI Driver Gets TV-Out Support](

Haven’t got a clue on the pros and cons one way or the other though, or whether it is model specific.

This also suggests opensource driver may be a better source for a how to…
HOWTO TV-Out - Gentoo Linux Wiki

May just need that xrandr bit <shrug>

Hmmm complicated…, thanks for this howto, I will try to follow that unless someone can confirm that SuSE 11 will solve my issue :rolleyes:

In the meantime I am open for new suggestions!

Well, xrandr seems to be the way to go. (I really can’t believe TV out was not enabled with a nice gui long ago… No newbie should have to walk this road. The problem lies probably with ATI :()

Well you can’t find xrandr in yast, it seems to be already implemented in SuSE 10.3 by default, but you have to activate it by changing the xorg.conf file. Note that you can break your X-window gui so please make a copy before…
Search for the following part:

 Section "Device"
  BoardName    "RV280 5961"
  Driver       "radeon"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "ATI"

and change it into this:

Section "Device"
  BoardName    "RV280 5961"
  Driver       "radeonrandr12"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "ATI"

Restart X and check if it is running. If the screen turns black, reboot in safe-mode and undo the changes. I did get the X-window gui back in a low 800x600 resolution.
Manual check version of xrandr:

$ xrandr -v
Server reports RandR version 1.2 

Now let’s see what is connected to the computer:

$ xrandr -q
Screen 0: minimum 320 x 200, current 800 x 600, maximum 2048 x 768
VGA-0 connected (normal left inverted right)
   1024x768       74.9     75.0     75.1     70.0     70.1     65.0     60.0     60.0
   832x624        74.6
   800x600        72.2     75.0     74.9     75.0     70.0     65.0     60.3     60.0     56.2
   768x576        75.0     70.0     65.0     60.0
   640x480        75.0     72.8     74.8     66.7     60.0
   720x400        70.1
DVI-0 connected 800x600+0+0 (normal left inverted right) 304mm x 234mm
   1024x768       74.9     75.1     70.1     60.0
   832x624        74.6
   800x600        72.2*    75.0     74.9     60.3     56.2
   640x480        75.0     72.8     74.8     66.7     60.0
   720x400        70.1
S-video connected 800x600+0+0 (normal left inverted right) 0mm x 0mm
   800x600        59.9*+   60.3

Yes! I see the S-video for television connection. To enable it I had to use:

$ xrandr--output S-video --set tv_standard pal
$ xrandr --output S-video --auto

$ xrandr --output S-video --off

Sadly this works for a lot of people except me :eek:. I definitely see my desktop appear on the television. But the sync or something else is horribly wrong. (scrambled picture)

Please any advice!
(Do not hesitate to post how you managed to watch video content on your television, even if it is not a ATI-controler you are using!)

… lot’s of people report xrandr is not working for PAL televisions with the default drivers shipped with SuSE 10.3. I can confirm that NTSC works (one of my televisions accepts NTSC)

The issue will have to wait until SuSE 11. Thanks for supporting me.


Can’t help you because I have a similar issue. Perhaps someone else can help me?

Problem: I activate dual head output and have signal om both monitors when BIOS is loading and as long as openSUSE is loading in text mode as well as the boot screen. But as soon as the logon screen appears the signal disappears from the secondary monitor. If I run SAX from within the booted and logged on system, I temporarily get a signal on the monitor (It runs some stuff in text mode I’m sure you know what I mean).

Bonus info: My primary monitor is widescreen and the secondary TV/monitor is very widescreen I guess. Sometimes my meddling with settings makes the primary monitor think it’s wider than it actually is, making it move as I push the mouse towards the edges of the screen (I’m sure you know what I mean).

For some reason I can’t run nvtv. Just doesn’t seem to start.

Specs: Linux x86_64; openSUSE 11.0 (x86_64); KDE: 3.5.9 “release 44”. Graphics: nVidia Corporation; GeForce FX 5200; Driver: nvidia (3D) 173.14.05.

Could be very mundane settings issue. Bugs me because shouldn’t this stuff just work!? Any comment appreciated!

Oeps, you run OpenSuSE 11 and use nvidia. I do not know about xrandr with those 2.

Try xrandr -q in a terminal (just as user) to see what is connected to your PC. (also do xrandr -v to see the used version)

[edit: ps; welcome to this forum!!!]

Thank you for your welcome and suggestion. The command gives this output…

> xrandr -q
Screen 0: minimum 640 x 480, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
   1680x1050      50.0*
   1600x1024      51.0
   1400x1050      52.0
   1280x1024      53.0
   1280x960       54.0
   1152x864       55.0
   1024x768       56.0
   800x600        57.0
   640x480        58.0

> xrandr -v
Server reports RandR version 1.2

1680 x 1050 is the correct resolution of my primary monitor now (doesn’t think it’s wider than that any more). I still get to see the BIOS and “pre-x” stuff on the TV but not the desktop.

First of all if 1680x1050 is the native resolution of your screen. Check the xorg.conf file in /etc/X11
Section “Screen” did you add a line “virtual” with numbers bigger than the ones below?

Virtual 1680 1050

That will be the reason you have the screen scrolling when you hit the mouse to the edges of the screen.

You can force the screen size (open a terminal) with:
xrandr --output Screen 0 --mode 1680x1050

or correct xorg.conf

Now for your TV, did you give the command xrandr -q with the television on? Look at my posts above. I have a S-video detected. You don’t!

Thanks for helping out. But I don’t have the wrong size issue any more (fixed itself) and I’d really prefer to have the secondary monitor added without editing config files. Later I’ll upgrade from Nvidia 5200 to 6200 (because I accidentally bought one online) and I ordered the openSUSE 11 Bible at Amazon so I won’t lose sleep over this issue right now but will look into it later.

Also note that I do get some signal to the TV - it’s just that it stops as soon as the nVidia logo appears on the primary monitor.

Ok, than you should seek help on the nvidia forums later when you got the new card. For sure they got a tool for you. Forget xrandr I believe it is more for intel and ati graphic cards.

PS; you can accidentally send the old nvidia card to me :smiley:

Use ‘nvidia-settings’ on nvidia cards

Use ‘nvidia-settings’ on nvidia cards


Can’t believe I missed that. Anyway, next up is a better cable and fixing the java browser plugin. :eek: