Watching DVDs

I’m trying to get DVDs to play on OpenSUSE 11.0. I’m trying to use Totem, since that is already installed and seems to be default. However, I’m missing a codec for it.

I found the restricted formats page in the sticky for 11.0:
Restricted Formats/11.0 - openSUSE-Community

I’m using Gnome, so I selected the gnome codecs. I click on this, and I get a list of packages that it’s going to install. This is the list it displays:

• ffmpeg
• flash-player
• gst-fluendo-mp3
• gstreamer-0_10-ffmpeg
• gstreamer-0_10-plugins-bad
• gstreamer-0_10-plugins-good
• gstreamer-0_10-plugins-ugly
• java-1_5_0-sun-plugin
• libdvdcss
• libxine1
• w32codec-all

When I get to the ‘Perform Installation’ part, it opens up the Package Selection for Yast. Umm, ok. Thanks for not installing these automatically…

I’m assuming that I need to go through and install each package. Well, I have all of them except:

• gstreamer-0_10-ffmpeg
• gstreamer-0_10-plugins-bad
• gstreamer-0_10-plugins-ugly

When I try to install gstreamer-0_10-ffmpeg, I get:

There are some conflicts on the transaction that must be solved manually. requires gstreamer-0_10 >= 0.10.21, but this requirement cannot be provided.

I also get something similar for the other two. Any advice on what to do?

I’m not sure I would use Totem but check this

Multi-media and Restricted Format Installation Guide - openSUSE Forums


So when I try to install libavcodec51 I get:

There are some conflicts on the transaction that must be solved manually.

nothing provides needed by

By the way, why would you not use Totem? I just tried using VLC. It works, but it is choppy. It is almost like the program won’t buffer the video. It only takes info from the dvd when needed.

I must be drunk or something :slight_smile:

I closed and restarted VLC, and it seems to be working fine now.

I suppose there is no need to get Totem working. VLC has always been great for me. Thanks caf4926!

Make sure you disable the vlc repo and then do update all in Packman
Just check too if you can add libavcodec52
(rather than libavcodec51)

Mplayer is probably the best IMO. But if Totem works and you like it fine. VLC probably needs the video output changing

switch the output video mode of your multimedia player from “auto” or from “xv” (xvideo) to “x11”

I was just checking the Packman repo and it has libavcodec51 and libavcodec52
use 52

Alright, thanks for the help caf4926. I have done everything you suggested and things seem to be in order now. Of course, if something else goes wrong, I’ll be back :wink:

Excellent. Well done.