Watch DVDs with VLS: at first nothing worked now i only have audio

i want to watch some old dvds of mine (real ones, bought a few years ago, nothing selfmade) using VLC because i know on windows this works.

At first when i tried to open the dvd in VLC it did not even react, then i tried Xine and at least it said that some MPEG codecs are missing. I found this site:
and installed all packages (from the current packman repo) and even added the libdvdcss repo and installed everything else.
After a reboot vlc (and xine) now plays the dvd but only the audio, when i click somewhere on the time bar the picture of the scene at this position is shown
but it does not change from that.

What can i do?

See if vlc-codecs is installed and that VLC and all parts of are installed from Packman.

vlc-codecs is installed (from packman) and i ma pretty sure everything vlc related is from packman too.

Have you tried changing the VLC output? Tools / Preferences / Video / Output?

Also try disabling Overlay.

I tried but it did not helped. Xine does not work too.

You tried disabling the hardware accelerated overlay on the same page?

Note, changing the video output sometimes requires you to close VLC completely and then open it again before the it takes effect.

Please run thru this

Yes, i did both. At first a disabled overlay and changed to a different output mode (normally i use opengl but i tried automatic, and some other X-video modes) i let overlay disabled all the time and after each mode switching i closed VLC before i tried.

I did this but, i had both the repositorys already added, they all where up to date too.
And typing:

zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs

did installed some new packages but if i noted it right, then most of the packages i already had installed, the only new ones where the GNOME gecko-multimedia player (which is strange because i use kde and this was the KDE part of the walkthrough) and its dependencies!
I restarted anyway and after that nothing changed i still cannot watch my DVD, i even tried other DVDs from the same box, all have the same problems.

i think i forgot to make the package switch that was described at the bottom of the walkthrough (i though switching when conflicts occurred already was the package switch) i will do this now and post my results.

this sadly did not help

Install handbrake
Does it offer the ability to rip the dvd

Yes it worked, i installed handbrake GTK+ and fiddled a bit with the options (i do not know about most of the settings i did) but in the end i had a mp4 videl file of the first episode of the show on the dvd (the DVD is the first DVD of a boxset of a season of a tv show and contains 4 episodes).
The ripped file plays fine though.

Then IMO you are missing something elsewhere when trying to play a DVD normally.

In most cases you need to point the software (such as VLC) to /dev/sr0

It is not that VLC is not finding the DVD or is not starting to play it, it is that VLC only plays the sound not the video.
But it is a bit more than that, when starting the DVD with VLC i hear the menu music, then when jumping to a point near the end of the menu videofile the menu suddenly appears, i even can click on the buttons! Then the episode starts but only the audio when jumping forward in the episode only a freezed image of the current scene is shown. This is the same when i open the VOB files on the DVD directly.

Have you installed libdvdcss?

Tried other media players?

Other media players can help. I have had this on odd occasion myself.

vlc media player installed-codecs is installed and i ma pretty sure everything vlc related.
GIS companies in India
GIS company in India
GIS companies in Ghaziabad

Yes i did install libdvdcss, it is on the list in the walkthrough caf4926 posted.
Other players i tried are: Xine, Mplayer and VLC
none of them worked.
But i just tried the Gnome player (the zypper command from the walkthrough included this, even in the KDE path)
and surprisingly it works!
The menu is animated now and has transition effects.

This basically solves my problem but i would be interested in finding out whats the problem for the other players, but this is low priority.
I do not expect any answers or solutions from now on soon.

different players may have different back ends thus may have different workarounds for DRM or other odd formatting choices of the makers