Wastebin has reached it's maximum size error

Whenever I try and move an item to the wastebin I get the following error:

The wastebin has reached its maximum size! Cleanup the wastebin manually

Using KDE 4.4, Opensuse 11.2.

However, when I browse to the wastebin it appears completely empty.

Thanks for any suggestions.

Do you have the option to right click ‘empty wastebin’

Thanks for the reply caf.

No that option does not appear, however if it may help I noticed some microsoft office recovery documents were in the wastebin at one stage and I could empty the wastebin. Moving files to the wastebin does not work.

What settings do you have in dolphin for the wastebin
and how much free space do you have in /home

Try to delete “manually”.
Delete all files located in these directories:


Good luck.

I’ve got 14GB free on \home. For Dolphin settings - Delete older files option is greyed out and Limit to maximum size is set to 10% (2GB) and when limit reached reads: Warn me.

I tried moving files to the wastebin in gnome and everything seems to be fine and dandy there.

I’ll just try out ram88’s suggestion and report back.

When I unchecked the limit to maximum size option in dolphin settings I could move files to the wastebin again, however re-enabling it causes the aforementioned error.

Unfortunately ram88’s suggestion did not seem to work.

Ok, now a bit hard part.
Become su in terminal and run this command. Run the exact command.
Note: Be very careful before running it.

rm -Rf ~/.Trash/*

Good luck.

Thanks for your help guys, unfortunately rm -Rf ~/.Trash/* didn’t help. However, playing around with the wastebin settings in Dolphin, I changed the setting (keeping all others the same)

WHen limit reached: Warn me.


When limit reached: Delete biggest files from wastebin

and everything started working perfectly again

Does this mean that I had some files in the wastebin which I couldn’t view?

This is my settings


But I always use ‘delete’ and bypass trash.

But I always use ‘delete’ and bypass trash.

It’s just that I’ve been used to the windows way of right clicking and selecting delete (which moves it to the recycle bin) whenever I’m not 100% certain that I might not need a file. Still getting used to Opensuse…

They are the explicit patches to the user’s (given in the <yourUserName>) Trash - what you see in Dolphin. If the folders under these patches are empty then your Trash is also empty.
Did you find these directories?

*<yourUserName> was a typo. So, if you are logged in with the user: xyz, then the correct patches are:





In winders just press SHIFT and delete, it bypasses the trash

But it’s a good idea to make sure you don’t need a file before giving it the 2 fingered salute.

Found those directories, they were both empty. Since the issue didn’t occur in gnome I’m guessing it was a KDE bug. There were a few other directories (such as expunged) didn’t touch those.

Thanks for sharing this… Had the same issue today and this solution worked perfectly for me…
Thank you once again… :slight_smile: :slight_smile: :slight_smile: