Warning messages about unknown symbols

Hi!

I have openSUSE 11.4. After a recent online update, I get the following warning messages, whenever I install a new package:


WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko needs unknown symbol ieee80211_get_tkip_key
WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/l2cap.ko needs unknown symbol bt_err
WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/l2cap.ko needs unknown symbol hci_unregister_proto
WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/l2cap.ko needs unknown symbol hci_register_proto
WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/sco.ko needs unknown symbol bt_err
WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/sco.ko needs unknown symbol hci_unregister_proto
WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/sco.ko needs unknown symbol hci_register_proto

The current kernel is: 2.6.37.6-0.11-desktop

Is there a way that I could get rid of these warnings?

Thanks!

On 03/28/2012 04:46 PM, gianluca4 wrote:
>
> Hi!
>
> I have openSUSE 11.4. After a recent online update, I get the following
> warning messages, whenever I install a new package:
>
>
> Code:
> --------------------
>
> WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko needs unknown symbol ieee80211_get_tkip_key
> WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/l2cap.ko needs unknown symbol bt_err
> WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/l2cap.ko needs unknown symbol hci_unregister_proto
> WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/l2cap.ko needs unknown symbol hci_register_proto
> WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/sco.ko needs unknown symbol bt_err
> WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/sco.ko needs unknown symbol hci_unregister_proto
> WARNING: /lib/modules/2.6.37.6-0.11-desktop/kernel/net/bluetooth/sco.ko needs unknown symbol hci_register_proto
>
> --------------------
>
>
> The current kernel is: 2.6.37.6-0.11-desktop
>
> Is there a way that I could get rid of these warnings?

You got a faulty install of that kernel. Try using YaST and reload the kernel.
That should fix it.

Thanks. I will try it out as soon as I hook my laptop to the internet. How do I re-install the kernel? Do I simply start software management and click on the kernel and choose re-install?

On 2012-03-29 08:06, gianluca4 wrote:
>
> Thanks. I will try it out as soon as I hook my laptop to the internet.
> How do I re-install the kernel? Do I simply start software management
> and click on the kernel and choose re-install?

Yep :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)