Warning about missing bios_boot labeled partition in install procedure


I wanted to install LEAP 15 on a system now running 42.2. I choose for fresh install, and importing the existing partitions and fstab labels.

When continuing, I get the warning

Missing device with size equal or bigger than 2 MiB and partition id bios_boot

Never seen this before.

The system has an EFI system partition, 164MiB, FS-type FAT, and no label, so I labeled it bios_boot, but that doesn’t help.

I would have liked to add a screenshot from the partitioning after labeling the EFI-partition, but adding attachments is not in my list of permissions…

Should I do something, or can I ignore the warning?

How are you installing?

You normally only see that “bios_boot” warning if you are trying to install for legacy booting. If you have a EFI partition, you should probably be installing for UEFI booting.

The installer can be booted using UEFI or it can be booted in legacy boot mode. I’m guessing that you may have booted the installer the wrong way.

Hmmm… During the installation process, I don’t encounter an option for UEFI or legacy.
Before that, in the choice for a boot device the BIOS presents me, there is indeed a choice between two options, one with, one without UEFI, on the flashdrive I do the installation from…
But it doesn’t matter which one I choose, in both variants later on the warning is issued.

Maybe it is of importance that I, in the partitioning procedure, I choose to import the existing partitioning scheme and mount points, and not to format /home.

As said, I’m not permitted to post attachments (why not??) so I can’t upload the screenshot of the partitioning scheme. But, again as said, in the existing partitions, there is an EFI system partition, mount point /boot/efi, size 164MiB, FS-type FAT.

I didn’t try to ignore the warning, because now I have a working system on Leap 42.2…

You can upload images to https://susepaste.org/ (button upper-right) and post the link in your post.

It should make a difference. But perhaps you did not notice.

I’m basing this on my experience. Without the UEFI boot, it complains about the missing bios_boot partition. With the UEFI boot, it instead complains that your EFI system partition is too small (smaller than 256M).

If you tried it both ways, then maybe you noticed a complaint both times, but did notice that they were different complaints.

In any case, here is my suggestion:

Try again. Be very careful to select the UEFI boot.

Then proceed as before, and import partitioning.

It will probably complain that you have not included an EFI partition of at least 256M.

Ignore that complaint. Tell it to continue anyway. And you should finish up with a good install.

OK, thanks!

nrickert;2883034]It should make a difference. But perhaps you did not notice.

Thanks for your answer, but I’m pretty sure I didn’t miss a choice.
Ran through the installation process several times, but never saw such a choice, apart from the one presented when choosing the boot disk in the BIOS start up.
And there, I choose “UEFI: Philips USB Flash Drive PMAP”

After that, the installer gives the option to boot from hard disk, Installation or Upgrade. I choose Installation. Next step is choosing the language (Dutch, in my case). After that, Network configuration, and, having that done, the partitioning process.

Where in this sequence I should expect a UEFI/non-UEFI boot?

I can upload images of several steps in the installation process to susepaste.org, if that is helpful.

Like nrickert says: if the complaint is about the size not being large enough, ignore and procede anyway.

OK, I ignored the warning, and the system boots after install. Thanks!
Still not sure which choice I missed, but well… Why is the warning issued anyway, when a much smaller EFI appears to be no problem?

The choice is provided by your BIOS. Once you are past that, there isn’t a choice. Well, if you know what you are doing, you can force the bootloader choice, but usually that’s a mistake. The BIOS choice is the important one.

Why is the warning issued anyway, when a much smaller EFI appears to be no problem?

Some of us have been arguing that in the bugzilla. But it’s too late for Leap 15.0. It may come up again with 15.1.

There are good reasons for creating a new EFI partition of at least 256M. However, those are not good reasons for objecting to a smaller sized EFI partition that already exists. And this warning in the partitioner has confused a number of users.

I should perhaps add that the partitioner was redesigned for 15.0, and this warning was part of the design.

In any case, we are glad to hear that you have a working system.

Similar issue here, but in my case in virtualized installation, under VirtualBox!?
See my screenshot:

The system might not be able to boot:
Missing device with size equal or bigger that 2 MiB and partition id bios_boot

Oracle VirtualBox 6.0.2 (latest version) + installation of openSUSE Leap 15.0 with Network Installer.
I changed the original suggested setup of multiple partitions and only created one, ext4, root / partition.
Why it even complaints about BIOS when virtualized!?


Presumably, VirtualBox is using an emulated BIOS to boot your system. If you switched it to UEFI, it would instead want an EFI partition.

If you are using “ext4” for the root partition, it will probably work if you continue (and ignore the error message).

Yes, it works perfectly without bios partition. I finished installation without any further issues and then was able to boot, and I am still able to boot.
The warning message is pretty misleading.

It is not entirely misleading.

Grub2 needs somewhere to install. And, if possible, it wants to install enough code to boot the system. But there is not enough space in the MBR for that.

On a legacy partitioned system, it steals space beyond the MBR which is normally unused. And it installs code there. With GPT partitioning, that space is not available because it can be allocated to a partition. So the bios_boot partition is to give grub enough space to install its boot code.

It can manage without in some circumstances. Instead of installing enough boot code to boot the system, it can install a tiny amount of boot code and some block pointers to where the rest of the boot code sits (in “/boot/grub2/core.img”).

If “/boot” is part of an encrypted partition, it cannot do this. If “/boot” is part of a file system such as “btrfs” that does not make the block pointer information available, it cannot do this. If “/boot” is part of an “ext4” partition, then it can work that way. In your case, you were using “ext4” so it works for you without the bios_boot partition.