WARINING! Using Virtualbox 4.0 from Oracle can cut down your samba or wifi

In case one day u can’t access samba or got no network, just deinstall your Virtualbix 4.0. and restart computer. See if you can access internet and samba then.
I didn’t copy/paste the samba and system logs, but the error was similar like here:

# insserv samba
insserv: FATAL: service syslog is missed in the runlevels 4 to use service

I don’t know if it also affects the OpenSource Edition of Virtualbox, but it happened just like that. I had network and samba and suddenly it was broken by some Virtualbox issue. Deinstalling helped. So if you see a similar error when (as root) you do

tail -f tail -f /var/log/NetworkManager or **tail -f /var/log/samba/log.smbd
** , than see if deinstalling Virtualbox helps. It can always be installed back and your virtual machines stay untouched.

One comment: I did not use the command insserv.

But I had exactly the same error when doing ifup wlan0.

Also Networkmanager reported in it’s log the same error, showing the vboxdrv… This made me uninstall Virtualbox 4.0 - very strange. But at least I know the guilty one.