Wanting to update to KDE4.2.4 but have dependency issues

Just trying to do an update to 4.2.4 but would like to check out what some of these dependency problems are before proceeding.

#### YaST2 conflicts list - generated 2009-06-11 09:01:34 ####

compiz-kde4-0.7.8-9.1.i586 requires libplasma.so.2, but this requirement cannot be provided

     ] Following actions will be done:
do not install compiz-kde4-0.7.8-9.1.i586
downgrade of compiz-kde4-0.7.8-9.1.i586 to compiz-kde4-0.7.8-8.11.i586
install compiz-kde4-0.7.8-8.11.i586 (with vendor change)
  openSUSE
-->
  openSUSE Build Service
     ] Following actions will be done:
do not install kdebase4-workspace-4.2.4-3.4.i586
do not install kde4-kgreeter-plugins-4.2.4-3.4.i586
do not install kde4-kwin-4.2.4-3.4.i586
do not install kdebase4-session-4.2.4-3.4.i586
do not install kdebase4-workspace-ksysguardd-4.2.4-3.4.i586
do not install kde4-ark-4.2.4-1.4.i586
do not install kde4-kcalc-4.2.4-1.4.i586
do not install PolicyKit-kde-0.2-8.10.i586
do not install kde4-dolphin-4.2.4-1.4.i586
do not install kde4-kaddressbook-4.2.4-2.4.i586
do not install kde4-akregator-4.2.4-2.4.i586
do not install kde4-kfind-4.2.4-1.4.i586
do not install kde4-kdnssd-4.2.4-2.5.i586
do not install kde4-kio_audiocd-4.2.4-1.4.i586
do not install kde4-kmix-4.2.4-1.4.i586
do not install kde4-keditbookmarks-4.2.4-1.4.i586
do not install kde4-kio_sysinfo-11.1.1-67.5.i586
do not install kde4-kcolorchooser-4.2.4-1.4.i586
do not install kde4-kgpg-4.2.4-1.4.i586
do not install kde4-kmail-4.2.4-2.4.i586
do not install kde4-konqueror-plugins-4.2.4-4.2.i586
do not install kde4-konsole-4.2.4-1.4.i586
do not install kde4-kmines-4.2.4-1.4.i586
do not install kde4-kerry-0.2.90-7.13.i586
do not install kde4-kgamma-4.2.4-1.4.i586
do not install kde4-kio_kamera-4.2.4-1.4.i586
do not install kde4-kget-4.2.4-2.5.i586
do not install kde4-kmahjongg-4.2.4-1.4.i586
do not install kde4-konqueror-4.2.4-1.4.i586
do not install kde4-plasmoid-quickaccess-0.8-3.11.i586
do not install kde4-okular-4.2.4-1.4.i586
do not install kde4-kwrite-4.2.4-1.4.i586
do not install kde4-plasma-addons-4.2.4-1.4.i586
do not install kde4-kontact-4.2.4-2.4.i586
do not install kde4-kopete-4.2.4-2.5.i586
do not install kde4-kpat-4.2.4-1.4.i586
do not install kde4-krdc-4.2.4-2.5.i586
do not install kde4-kreversi-4.2.4-1.4.i586
do not install kde4-krfb-4.2.4-2.5.i586
do not install kde4-kscd-4.2.4-1.4.i586
do not install kde4-ksnapshot-4.2.4-1.4.i586
do not install kde4-ksudoku-4.2.4-1.4.i586
do not install kde4-kwalletmanager-4.2.4-1.4.i586
do not install kdebase4-4.2.4-1.4.i586
do not install kdenetwork4-filesharing-4.2.4-2.5.i586
do not install kdeartwork4-screensaver-4.2.4-1.4.i586
do not install kdepim4-4.2.4-2.4.i586
do not install skanlite-0.3.kde4.2.4-2.1.i586
     ] Ignore some dependencies of compiz-kde4



amarok-yauap-1.4.10-26.1.i586 requires libamarok.so.0, but this requirement cannot be provided
uninstallable providers: amarok-1.4.10-100.pm.2.i586[repo_1]
     ] deinstallation of amarok-yauap-1.4.10-26.1.i586

     ] do not install amarok-2.1-2.1.i586

     ] Ignore some dependencies of amarok-yauap



digikamimageplugins-0.9.4-51.18.i586 requires libdigikam.so.0, but this requirement cannot be provided

     ] deinstallation of digikamimageplugins-0.9.4-51.18.i586

     ] do not install digikam-0.10.0-5.2.i586

     ] Ignore some dependencies of digikamimageplugins



kde4-gwenview-4.1.3-4.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided

     ] Following actions will be done:
do not install kdebase4-runtime-4.2.4-2.4.i586
do not install kde4-kcalc-4.2.4-1.4.i586
do not install kde4-dolphin-4.2.4-1.4.i586
do not install kde4-kaddressbook-4.2.4-2.4.i586
do not install kde4-akregator-4.2.4-2.4.i586
do not install kde4-kfind-4.2.4-1.4.i586
do not install kde4-kio_audiocd-4.2.4-1.4.i586
do not install kde4-kmix-4.2.4-1.4.i586
do not install kde4-kio_sysinfo-11.1.1-67.5.i586
do not install kde4-kgpg-4.2.4-1.4.i586
do not install kde4-konqueror-plugins-4.2.4-4.2.i586
do not install kde4-konsole-4.2.4-1.4.i586
do not install kde4-kmines-4.2.4-1.4.i586
do not install kde4-kerry-0.2.90-7.13.i586
do not install kde4-kio_kamera-4.2.4-1.4.i586
do not install kde4-kmahjongg-4.2.4-1.4.i586
do not install kde4-plasmoid-quickaccess-0.8-3.11.i586
do not install kde4-kwrite-4.2.4-1.4.i586
do not install kde4-kontact-4.2.4-2.4.i586
do not install kde4-korganizer-4.2.4-2.4.i586
do not install kde4-krdc-4.2.4-2.5.i586
do not install kde4-krfb-4.2.4-2.5.i586
do not install kde4-ksnapshot-4.2.4-1.4.i586
do not install kde4-kwalletmanager-4.2.4-1.4.i586
do not install kdebluetooth4-0.3-8.7.i586
do not install kdenetwork4-filesharing-4.2.4-2.5.i586
do not install kde4-kwin-4.2.4-3.4.i586
do not install kdepim4-4.2.4-2.4.i586
do not install skanlite-0.3.kde4.2.4-2.1.i586
do not install kdebase4-session-4.2.4-3.4.i586
     ] Ignore some dependencies of kde4-gwenview

     ] replacement of kde4-gwenview-4.1.3-4.7.i586 with gwenview-4.2.4-1.4.i586

#### YaST2 conflicts list END ###

I’ve done as described in the post about updating KDE and have added KDE42 and the KDE community repos. I also have the standard 4 repos as recommended.

EDIT: This is being done on a virgin install of 11.1 with KDE4.1. I’ve not run any of the online updates yet.

Fastest solution:
Uninstall amarok* and digikam*. Reinstall them after updating KDE4. * is for all packages.
Then start the updating process again. Two dep-problems remain, compiz and gwenview.
On compiz: pick the first option, to downgrade
On gwenview: replace kde4-gwenview by gwenview.
Now the updating process should continue. After it’s finished, reinstall amarok and digikam.

Good luck, if you don’t get through it, get back to us and we’ll help you out.

Thanks. That seemed to work.

I guess it’s a strategy I could use in most cases where I just uninstall the offending app and then reinstall after.

What made you decide to downgrade compiz? Casn I just upgrade it again now?

I find the app naming conventions really confusing. E.G, the digikam. there is a digikam and also a KDE4_digikam, so logic says to try install the kde4 version but when you do it says digikam supercedes it. Why don’t they just stick with one convention?

I also noticed that I have a whole bunch of kde3 stuff installed. Why is this stuff installed when I have the kde4 desktop? For example in my kickstart panel under File Manager I have:
File Manager (dolphin)
File Manager (super user mode)
File Manager (konquerer/kde3)
File Manager (konquere/super user mode kde3)

What are the kde3 versions doing there? Can they be removed? There are other similar examples.

So confusing.