Wanted Gnome, installed KDE

While installing Suse 12.3, I inadvertently opted for KDE rather than Gnome.

Is there any simple way to switch over to Gnome?

Could some kind person help me make the switch?

I don’t have much knowledge at all, so please be gentle!


Open up YaST / Enter root user Password / Goto Software / Software Management / Select the View button on Top Left and Pick Patterns. You should see a couple of Patterns you must select that will load Gnome, check them and pick the OK button on bottom right. A lot of packages must be installed. Once complete, restart PC. Once you get to the Login screen, you must select Gnome from the menu, to go into GNOME. You use the same selection to switch back to KDE. You always by default log into the last selected Desktop.

Thank You,

zypper in -t pattern gnome

Or open YaST package management, search for pattern “Gnome” and install it.

Then logout, choose at the desktop manager “Gnome” and login.

it should be possible to put that DVD back into the drive and install gnome

Because jdmcdaniel was the first, I tried his sollution.

All went according to plan, but when I rebooted there was no login box, so I had nothing to choose, and I think that I am still on KDE.

How can I check - this is a new form of Suse so I am not familar with what Gnome should look like - and, if I have gone wrong (although I can’t see how!) what should I do?


logout and choose “gnome” session.

I did and still no options.

I had a look at Software Manager and a Warning box was in place:

An error ocurred during repository initialisation.
'repo-update-non-oss: http://download/opensuse.org/update/12.3-non-oss/[repo-update-non-oss|http://downloa.opensuse.org/update/12.3-non-oss/]
Repository is not cached.

I went back to View and under Graphical Environment both GNOME Desktop Environment and Gnome Base System are ticked along with the KDE equivalents.

What have I done wrong?

When you logout you should get to the login screen.
There should be a “gear” symbol. (below the user list, left of the “shutdown” symbol and the current date)
Click on this and you should be able to choose GNOME amongst others…

OK! Now I have it!

My previous Suse was 11.4 and a little different. Now I have Gnome. Thanks a lot for your help.

And if you want GNOME’s GDM as Login Manager, you can set that in /etc/sysconfig/displaymanager…

If you want old sort of gnome press win key ==> type details ==> open application. ==>Turn on “fallback” ==>logout and login into “kind” of legacy gnome.