Want to update to use UEFI

My system boots OpenSUSE, Mint, Neon and Windows. UEFI was disabled back in ancient history.

In preparation for a Windows 11 upgrade, I would like to configure OpenSUSE to use the EFI partition that is on the system.

Is the method as simple as configuring /etc/fstab with an entry for /boot/efi? What do I need to do?

Does /boot/efi exist on your OpenSuse system currently, I ask because my VM instance of TW uses legacy BIOS and does not have it.

You would also need to switch the BIOS firmware from legacy mode to UEFI mode.

As per the docs [0], the minimum pre-requisites would be having a GPT partition table and ESP (EFI system partition). Then from Yast Bootloader > choose grub2 efi option.

Docs [0]:

Start by checking the partitioning of your hard drive. Since there is already an EFI partition, there is a good chance that it is using GPT partitioning. But check that.

If it is using DOS partitioning, then you will need to repartition if you want to install Windows 11.

The rest of the reply assumes that you are using GPT partitioning.

That would be a first step.

Here’s what you can try, but whether it works will depend on your BIOS.

Now go to “/boot/efi/EFI/Boot” as the root user. That last “Boot” in the path might actually be “BOOT” or “boot”. Remove all of the files in that directory. It might be wise to save a copy, perhaps move them to another directory in the EFI partition, in case you ever need to get them back.

Next, use Yast bootloader. The first screen will say that the boot loader is “GRUB2”. Change that to “GRUB2 for EFI”.

What is shown on the screen should then change. There will be a box for “Update NVRAM entry”. Make sure that box is unchecked. Otherwise you will get an error on attempting to install EFI booting.

There will also be a selector for “Protective MBR flag”. That likely will be set to “remove”. This is appropriate, but it’s a good idea to check.

Click “OK” (near right bottom).

Assuming there were no errors, try booting. This is the tricky part that depends on the BIOS. On my Dell system, hitting F12 during boot brings up a BIOS boot menu. It might be a different key in your case.

On my system, on of the boot choices would be “UEFI OS”. If you have that choice, then select it. That should boot your system, and possibly also add a needed NVRAM entry for future booting.

If this does not work, then you will need to use an openSUSE install media or an openSUSE live media, and use the “efibootmgr” command to manually add an NVRAM entry. I’ll skip the details on that until you reply to this.

1 Like

BIOS may offer “boot from file” where you can select shim/grub on ESP.

1 Like

Thank you for your prompt answers.

  1. The EFI partition is there since I dual boot with windows. I haven’t linked to openSUSE yet. My BIOS has an option to turn UEFI on or to use a combination of legacy and UEFI.

  2. I did use GPT partitioning when I created the drives.

  3. I will try it tomorrow.

The changes should leave your Tumbleweed system capable of booting either with legacy or with UEFI. The grub boot menu should have an entry to boot Windows, but that will only work with UEFI booting.

I mounted the efi partition at /boot/efi by editing /etc/fstab.

I was able to use yast to set up the “boot with efi” command.

I verified that I could boot.

Then I turned on the “uefi” option in my BIOS and rebooted. It worked@

Thanks to everybody for their kind advice.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.