want to install Plasma 5 alongside GNOME

I tried to install Plasma/KDE desktop alongside GNOME on a laptop. GNOME 3.20 is working very well, but KDE performance is extremely slow.

I tried:

  1. checking the compositing settings switching between xrender and openGL
  2. I hid tracker-miner, tracker store etc. from KDE
  3. I disabled compositing altogether
  4. I also checked the autostart config files and folders for anything unusual there.

None of these things had any effect whatsoever and the performance is so slow that the desktop remains unusable.

I would appreciate any help.

My hardware for this is an ACER e5-573 with i7 processor and 16GB RAM
GNOME works very well, other desktops I tested all ran very quickly too.

I should add that I also made sure in etc/syconfig editor in YAST that ssdm is my default display manager and kde (kwin5) the default window manager

The DM should not matter in general. How did you install Plasma? Maybe you missed packages

As gogalthorp wrote, there’s no need to use sddm with Plasma5. OTOH, GNOME does depend on gdm to some degree AFAIK (I think at least the screen locker only works with gdm), so you might be better off switching back.

If you want Plasma5 as default, you should set DEFAULT_WM to “plasma5”, not kde or kwin5 (both are invalid and will actually give you IceWM).
SDDM ignores that setting though, it currently has “plasma5” hardcoded as default in openSUSE.

In the end that doesn’t matter much though, as you can select the session on the login screen anyway, and it should be remembered.

Regarding your problem with the “performance”:
it might be KDE’s file indexer, try to disable it in “Configure Desktop” (systemsettings5)->Desktop Search->File Search.

I don’t think your problem is caused by missing/broken OpenGL hardware support, because that would make GNOME slow/unusable too.

It might be worth to check whether some process uses a lot of CPU though, either use “top” for that or KDE’s system monitor (Ctrl+ESC).
And it might also be a good idea to explain the problem in further detail. What exactly is slow/unusable?

I’ll try changing the window manager to Plasma5 as default…
Somebody suggested missing packages…
I installed it through Yast Software manager using the patterns… I checked to see if all the necessary files were installed. I installed this way on another laptop (older machine) and there it worked perfectly from the word ‘go’!
What I’ve done now is I completely cleared everything KDE and plasma related, deleted any config files in my home folder, .local, and others.

I do have a very smooth and snappy GNOME desktop running right now, but I will try once again…

Checking the System Monitor for CPU RAM and system performance showed no strange issues and loads were all within normal ranges… no files or processes hogging anything (this was while I was still in a Plasma session).

I’ll give it another spin and see. I prefer Plasma 5 to GNOME 3 so I hope it works.

thanks for all these pointers… I’ll try again and get back here with the result…

Note that it’s “plasma5” (lower case, that’s significant).

But as explained, it probably won’t make any difference.

Somebody suggested missing packages…

I think missing packages would cause different problems, not the one you experience…

I installed it through Yast Software manager using the patterns…

Should be fine.

I’ll give it another spin and see. I prefer Plasma 5 to GNOME 3 so I hope it works.

Well, it should work.

But except the file indexer “problem”, it might actually be a graphics driver issue as well.
Plasma5 (and Qt5) does use OpenGL in a different way than GNOME, so even if one works fine there might be problems with the other.
Though using “XRender” for compositing (or disabling compositing altogether) should rule that out I think.

It would still be interesting to hear what exact performance problems you have.
(if they still occur…)

judging by the type of problem it is I am inclined to think it’s something to do with the graphics card but I did (a few months ago) have Plasma 5 installed before on the same machine using EGL and openGL3.1 and it worked fine. However, when I disabled compositing it did not improve the performance. I’ll install Plasma later today and see what happens.

OK, after removing all kde and plasma files ,packages, folders, and patterns (yast) AND op top of that removing every config file, local files and anything KDE or Plasma related, ensuring there was a good installation of GNOME 3.20 on the machine…
I then installed Plasma 5.
It works like a breeze! (excuse the pun, it is intended) :wink:

Everything is working fine, and the display was set to GLX automatically, last time it went to Xrender. I tried EGL now and it all works perfectly. No performance problems at all.

So what was the problem the first time round? Well, maybe there was just some weird rubbish in my home folder. At least, that’s what I think because everything else I did the same.

Thanks for all your help as well as useful explanations, some of which I will implement now anyway.

Bottom line, I have a good working Plasma 5 session on Tumbelweed along with a good working GNOME session which I can use any time. I’ve been playing around a little and all is good.

Actually, Plasma 5 handles the graphics a bit better than GNOME seemingly, I don’t get any tearing at all.

I forgot to mention, I use Bumblebee for the graphics as I am unfortunately lumbered with an NVIDIA Optimus dual graphics adapter set up. I did nothing with that though it is still the same. I can still use my NVIDIA card at will.

Thanks guys.