Want to install package from openSUSE Build Service

package won’t install because Yast doesn’t have repository.

linux-cms6:/home/randall # zypper ar http://factory.opensuse.org
System management is locked by the application with pid 3784 (/usr/lib/YaST2/bin/y2base).
Close this application before trying again.
linux-cms6:/home/randall #

What do I need to do?

What do you want to install?

Normally, if you select a package from OBS using 1-click install, it will install the repo at the same time. Are you saying that this process does not work for your selected package?


I did killall y2base (or something to that effect, going by vague recollection) then
randall@linux-cms6:~> su
linux-cms6:/home/randall # zypper ar Index of /factory/repo/oss
If only one argument is used, it must be a URI pointing to a .repo file.
addrepo (ar) [options] <URI> <alias>
addrepo (ar) [options] <file.repo>

Add a repository to the sytem. The repository can be specified by its URI or can be read from specified .repo file (even remote).

Command options:
-r, --repo <file.repo> Just another means to specify a .repo file to read.
-t, --type <type> Type of repository (yast2, rpm-md, plaindir).
-d, --disable Add the repository as disabled.
-c, --check Probe URI.
-C, --no-check Don’t probe URI, probe later during refresh.
-n, --name <name> Specify descriptive name for the repository.
-k, --keep-packages Enable RPM files caching.
-K, --no-keep-packages Disable RPM files caching.
-f, --refresh Enable autorefresh of the repository.

linux-cms6:/home/randall #

Regarding one-click install, it starts up, but then I get this error message: “An error occurred while initializing the software repository. Details - opensuse Factory |] Valid metadata not found at specified URL(s). History - signature verification failed for content. Try again?” Try again don’t help.

You mean this: