Want to add more resolution


My motherboard is Intel D102GGC. My disply card is ATI Radeon X200(onboard).

I want to add 1152x864 screen resolution.

Currently the “Display” section is displaying this resolutions to select:

I was Ubuntu user before OpenSUSE. In Ubuntu, I can also see only this resolutions. So I run this command:

cvt 1152 864

Then copy the output and paste in XORG.CONF file. I don’t know about how to do this in OpenSUSE.

Please help me with this.


If you are using 11.2
Then by default there is no /etc/X11/xorg.conf
You need to run sax2 to create one, but that’s not necessarily the best option.

Check this for help
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

This link has so many option and I am confused how to do.

Can you please guide me how to achive without breaking anything?

Also I have tried “glxgears” and I can see gear perfectly. So I think drivers are installed.

I want to insert 1152x864 resolution.

Sorry if I misunderstood.

Find sax2 in the menu and start it

post a screen shot of it. I want to see the settings in there.

I don’t have much time ATM, I’m off out. But will be about early morning UK time 3am onward.

Adding extra resolutions that don’t nominally show up tends to be non-trivial. I can’t do it myself without surfing a lot for solutions - and even then there is no guarantee I’ll succeed. Of course what helps is to know (1) what openSUSE version a user is using, and (2) what graphic driver a user is using, and (3) what may be in the xorg.conf file, where (PasteBin.be is a good place to put that information) and ALL of that information is lacking on this thread.



will often tell one what resolutions are available with one’s current graphic driver in its current configuration.

… but I confess even if I had that information, I may not be able to help.

Here is “xrandr” output:

bimal-desktop:~ # xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 3840 x 1920
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 310mm x 230mm
   1024x768       85.0*+   85.0*    75.0
   1280x1024      60.0
   800x600        85.1     75.0
   640x480        85.0     75.0     59.9
   720x400        70.1
S-video disconnected (normal left inverted right x axis y axis)

and ???

please provide the above information.

Hey all

Thanks for your help. The problem is solved.

When I run “sax2” than nothing happen and I was lost my desktop screen. Then I restart and my desktop is back. I think “sax2” would broken on installation time.

So first step, I have completely updated my system. After restart, “sax2” is working. Second step, I checked in “sax2” and I found lot’s of screen resolution and 1152x864 resolution is also there. I selected and applied. Wow, resolution is set. Nothing to do.

I think my OpenSUSE 11.2 installation was not proper. I had seen two/three error on installation time but I ignored all. Although I have checked my ISO with Hash number and it is correct. I think my DVD drive is not proper working (I need to confirm this).

It’s my great experience in OpenSUSE that screen resolution is not headache and can set it easily. (I had done so many experiments with Ubuntu to get correct screen resolution.)

Thanks for your help guys.

It’s always a good idea to update after install.
Remember to that a CD install is way less flush with installed packages than a DVD install. Though sax2 should have worked.
But if your install was in any way corrupt or lacking, post install Update usually does the trick.

… what I do, is keep a digital camera next to my PC when I do an install. If I see any weird error message, I immediately snap a pix of it. It is easy to recharge the camera’s batteries and easy to delete the pix afterward, so there is no cost of taking such a pix and knowing the error can save wasted time later.

On thing that is important (learned from experience) is to burn to an +R or -R CD/DVD and not to an RW. Also burn at the slowest speed. Even though one’s CD/DVD passes the various checks, not burning at a slow speed to the proper media can cause a poor installation.

Glad to read of your success.