Wallpaper not showing on random boots

I just updated to Plasma 6.0.5. This has been happening since installing Plasma 6.0 fresh on my laptop. On random boots, I will get black wallpaper. Everything works fine but I have to set my wallpaper. This can happen on my laptop monitor or my external desktop monitor. I rarely run with both monitors active.

Any ideas? Still happening in Plasma 6.1.1.

Check this file: ~/.config/plasma-org.kde.plasma.desktop-appletsrc

This file keeps the configuration of your desktop.
Once a time in Plasma 5, I had a problem with this file being corrupted. I solved this by making it read-only. :wink:

Thanks. It seems pretty long. I have no idea what to look for but I will research it. Can I safely delete it and start over? I assume that will reset my desktop to default.

EDIT: I just deleted (moved) the file and set up my desktop again. Hopefully that will fix it. Is there anything else I need from the original file?

Is this definitely on login direct after a boot, or also after login.

It seems to happen at login because I can log out and log back in to trigger it. I’m sure it a Plasma startup issue. I wound up restoring the original “plasma-org.kde.plasma.desktop-appletsrc” file. It may be confused by my dual monitor setup since I sometimes use the second (external HDMI) monitor and someti8mes use the laptop monitor only but it can boot with no wallpaper when no external monitor is connected.

Which wallpaper is disappearing, the one in login screen or the one in desktop?

Desktop wallpaper. I normally use autologin because the disk is encrypted so I am entering a password at boot.

Can I log what happens when Plasma starts?

Could you show a screenshot of the screen where you set the wallpaper with the wallpaper you are having problems selected?

You can read the logs with journalctl.

It could be any wallpaper. I usually use the regular wallpaper dialog (right click on desktop). I have used Digikam to set wallpaper but in testing, I stick to the regular dialog.

I can’t find anything useful in the logs. This must not affect a lot of people. I’m convinced that it has to do with my multiple monitors. The settings show (correctly) that the built-in monitor is disabled (laptop is closed). It booted with wallpaper when I turned on the laptop but on a test reboot, no wallpaper. It’s maddening. Fortunately, everything else is working fine. I have the July bugfix Plasma release (6.1.2) but it didn’t fix the issue.

How is Plasma supposed to keep track of wallpaper and set it on boot for both monitors? When I set wallpaper on my external monitor, does it change it for the disable built-in monitor if the next boot is on the laptop away from my external monitor

I just did a test. I thought that maybe the wallpaper needed to be in .local/share/wallpapers but it doesn’t seem to matter. I chose a wallpaper I knew was there. The filename is showing here in plasma-org.kde.plasma.desktop-appletsrc:

[Containments][131][Wallpaper][org.kde.image][General]
FillMode=2
Image=file:///usr/share/wallpapers/openSUSE-default.xml
PreviewImage=/home/telliott/.local/share/wallpapers/Sweet-Wallpapers/Sweet-space.png
SlidePaths=/home/telliott/.local/share/wallpapers/,/usr/share/wallpapers/

Just confirmed the wallpaper is there but I just have a black screen on a test reboot.

I can’t reproduce this behaviour.
As a workaround, try running the command below and see if the misbehaviour continues.
chmod -c -w ~/.config/plasma-org.kde.plasma.desktop-appletsrc

Had a look in my boot journal today and saw in red:

plasmashell[1835]: qml: The backend got an unknown wallpaper provider type. The wallpaper will now fall back to the default. Please check your wallpaper configuration

I have no problems with the wallpaper except for this message but like to have a boot log without “red’s” so did go to the KDE System settings and did there explicitly set the OpenSUSE Default. Did reboot but that did not remove this warning.

> grep -i wall  ~/.config/plasma-org.kde.plasma.desktop-appletsrc
wallpaperplugin=org.kde.image
wallpaperplugin=org.kde.image
[Containments][30][Wallpaper][org.kde.image][General]
Image=/usr/share/wallpapers/openSUSEdefault/
wallpaperplugin=org.kde.image