Wake up after standby problem on HP Elitebook 8530w

When I do the suspend to RAM, opensuse 11.2 doesn’t open again. It just blank screen, and all the button including the hard wired one don’t give any response. I updated my laptop’s bios to the latest one, but didn’t solve my problem. Is there any suggestion that I can apply? Thanks

Check these
Pm-utils - openSUSE
Suspend to RAM - openSUSE

May help


Ok, I checked that stuff. I booted with vga=0 into
runlevel 3, so no X, no framebuffer. s2ram with various options always ends up in black screen after resume. System is still alive (capslock & takes commands on command line, e.g. reboot).

Clueless so far, but will keep trying from time to time.


Ok, solved,


HP EliteBook 8530w [Linux Laptop Wiki]

> Jesper, Wednesday 18 of November, 2009 [13:20:47] > In OpenSuSE 11.2, I had to disable the pcmcia
> scripts in pm-utils for suspend to work.
> touch /etc/pm/sleep.d/45pcmcia
> chmod 755 /etc/pm/sleep.d/45pcmcia
> See
> https://bugzilla.novell.com/show_bug.cgi?id=551303

The same worked for me.