wake-on-lan doesn't work after pxe secure boot

So, I played around a bit with my different systems I have lying around. I’m a fan of PXE boot, but only used it to boot non-UEFI / legacy systems without secureboot. Then I started to fidle around with UEFI PXE boot - but as I used a self compiled iPXE I had to disable secure boot. Until then I was able to remotely start up my systems via wake-on-lan, which is kind of important as the physical cases are somewhat obstructed and it’s hard to reach around to press the physical power button.
Then I tried pxe boot uefi with secure boot enabled and as the opensuse bootx64.efi loaded I got prompeted to trust its key. As I selected yes to get along it installed the master public key into the uefi key table to establish the trustchain. My tests are all went good and after playing around for a few hours I got back to my original setup. It was not until a day later I noticed that for some reason I’m not longer able to wake up the systems via WOL, none of them (yes, very unfortunately I have tried it on all systems - so all show the same issue). I also have all my systems set up to auto power on after power loss - which can easy tested by unplugging them. Again: for none of my systems this work anymore, so even disconnecting the power does not have them to power on after replugging them, which they did before my play around.

I also tried to disable secureboot and set them to bios legacy / csm mode - but issue still persists.

As the only thing that changed are installing of the opensuse key I can only asume that this has something to do with this issue. Don’t get me wrong - I’m not here to blame anyone - as I guess this is some side effect caused by the specific implementation of the board manufacturer - but I also can’t deny that at least for me it looks like having the opensuse efi start and install its key into the uefi caused this.
Hence I’m seeking help if anybody here has some experience with this or maybe can guide me into a direction where I may can get additional information?
The boards manufacturers deny support as the boards are long end of life and I’m just a regular private personal customer.

As for the boards:

ASUS Crosshair V Formula Z
Biostar A68MDE