Wacom Bamboo

Good day people,

I have a problem with my new Wacom Bamboo graphic tablet. It doesn’t work.
So far I tried:

  1. Installing wacom module through Yast but it didn’t do much.
  2. Compiling wacom module from source I got at Linux Wacom Project. Didn’t work either as the ‘make’ command results in numerous errors and the configure script doesn’t include wacom kernel module into config even though I use --enable-wacom switch :confused:

If any one of you did get it to work, would you please tell me how? Pretty please?


There is a blog here where a user managed to get a different model wacom to work:
Moosy blog - Wacom Volito tablet in OpenSUSE

I’ve never tried to configure a graphic tablet myself. But my wife purchased a DLA-401 Digital Note Recorder (a different model graphic tablet) and she has challenged me to get that running under Linux. < with evil grin on her part > …

To clarify, my wife is a big WinXP fan, and the DLA-401 comes with WinXP support. But no mention of Linux. Of course she paid no heed to Linux compatibility when she purchased it. Sometimes I think she does this sort of purchase (without some Linux compatibility research before hand) as a challenge to me, to see if I can get new hardware working with Linux.

I’m not confident I am up to that challenge, especially since a large portion of the support for that device happens to be in the Thai language. :eek:

There is also a linux wacom project page, with links to howtos and stuff:
The Linux Wacom Project

One more link … this openSUSE page also has information for stand alone tablets, and is not dedicated to just Tablet PCs.
TabletPCs - openSUSE

When viewing the above page, don’t over look the build service repository with updated applications for tablet PCs. For openSUSE-10.3 its here:
Index of /repositories/home:/dkukawka/openSUSE_10.3

Thank you for the reply (all four of them :wink: ) But unfortunatly I have already tried all of the above :slight_smile: :frowning: And none worked. The prebuilt module for SuSE is version 7, however to my dismay my particular hardware is only supported by version 8 and up, and that one is very new…
As for the website and howto there - I tried that too, but the module just wouldn’t build for some reason, even with all the dependancies in place.

OK, … well, … good on ya for doing all that research! :slight_smile: Sorry to read it wasn’t successful. :frowning:

You could submit a request to the build service to have the wacom driver redone for the bamboo (assuming bamboo support is in the driver). I have not submitted a request to the build service myself, so I can’t really help there.

Or alternatively, try contact user dkukawka and very very politely, ask if he has some suggestions on how to build the package?
User: Dkukawka home page - openSUSE
I note it is his repository (repos) that has the latest tablet rpm packages, and he did do his thesis in tablets. :slight_smile: And on his web site, he does state: "If you need some help to get you Tablet PC running feel free to ask me. "

I suspect I will be contacting him about getting my wife’s table to work, … BUT not before I research her tablet a bit more, and try some things on my own first.

Thanks for all your help people. I’ve upgrated to 11.0 and all is working now out of the box :smiley:

Excellent! and Congratulations! I note enhancement #302889 was for increased Table Support in SAX2, and I’m wondering if this was the enhancement that did it for you, when you upgraded to 11.0
Feature_No:_302889.29: add_more_Tablet_PCs_to_SaX2_Tablet_Section

Looks like I will have to update my wife’s PC’s openSUSE-10.3 boot partition, to 11.0 to test her tablet. I probably should do that, before I am pushed into contacting user dkukawka, else I will likely be wasting his time. On the bright side, I obtained a LOT more confidence in 11.0 last night, when I nailed down the problem that had been plaguing me in 11.0 (from beta2 to RC1 to GM) as a hardware (intermittent hard drive) problem. I’m happily running 11.0 in my test PC (with a different older, and very small, hard drive) and I may start upgrading the rest of the PCs in our house to 11.0 over the course of the next few months. [and buy a new larger hard drive :slight_smile: ]

Mine used to work in 11B1 but doesn’t any longer. Would you mind emainling a copy of your fstab and xorg.conf files to amau@sympatico.ca so I don’t tear my hair out trying to get this thing working again.


if u can’t make ur configure option --enable-wacom to be yes, try this:

(described in /usr/include/linux/version.h)

cd /usr/src/linux"
make mrproper"
make cloneconfig"
make prepare"

of course u have to install kerner-source, I did that via YaST.

if u got a lot of strange error when make, see if package ‘xorg-x11-server-sdk’ installed or not? (via YaST too)

if u got error about missing modpost script when make, do this (need to be root):

cd /usr/src/linux-2.6.22.xx-x.x
make scripts

I did these following steps too , but dunno if it’s really necessary

make oldconfig (under /usr/src/linux)

installed package: kernel-syms

after I did these, I can compile wacom.o/wacom.ko successly.

then following The Linux Wacom Project copied wacom.ko, found out the event num via wacdump, modified my xorg.conf …

those hid.o evdev.o blah blah all are not enabled in my configure, seems no effect.

now bamboo works for my X, and in GIMP u need to setup extended input device in GIMP’s preference dialog. I make erase, style, pad all to screen mode.

now it works well for me.

my kerner version is, updated via YaST.

linuxwacom driver version is 0.8.0-3

wish that help.

Wacom USB tablet howto - openSUSE

Thanks, though I have long since managed to get it working :slight_smile: All it took is SuSE 11 upgrade, and the bloody thing just worked rotfl!