VVV (Virtual Volumes View) Question

I have been looking for an open-source Disc Cataloger (something like Advanced Disc Catalog for Windows) for several years. Virtual Volumes View looks like it will do everything I want.

After downloading the 64 bit Linux version, I was surprised to find that it doesn’t “install”, but rather runs from a script. I can’t make it run. I have exchanged several emails with the developer but haven’t had any success with it at all. I don’t see how the script could cause much to happen (it doesn’t) or how an “Embedded” database might work.

Does anyone have any experience with this application? How is it supposed to work? What am I doing wrong?


So the program loads fine for me so perhaps you just don’t understand how to start it up. So, I extracted the entire archive into my Downloads folder, which on any system can be referred to as ~/Downloads.

The script then is at the path/name: ~/Downloads/VVV-1.2-x86_64/vvv-start.sh

I can then do a Alt-F2 and enter ~/Downloads/VVV-1.2-x86_64/vvv-start.sh, and the application will startup and run. I extracted the entire archive which included 60 files, 21 sub-folders at a total size of 16.6 Mib, with no CD directories added. If you extract it somewhere else, you must change the full name accordingly.

Thank You,

Just tried it here, works fine for me? Extract the tarball and cd into
the directory, then run;


I had to install libpng12-0

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 1 day 22:21, 6 users, load average: 0.06, 0.06, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

I only have 51 files, 21 sub-folders at a total size of 13.0 Mib so there must be something wrong with my download or extraction. I will try it again.

Also, thank you for clarifying the startup procedures.


I downloaded the 64 bit version. Perhaps you got only the 32 bit version, but I am not sure about that.

Thank You,

I started over with a new download of the 64 bit version. This time I received 50 files, 21 subfolders and a total size of 13 mib.

I ran it from konsole, where it told me (just like malcomlewis) that I needed to install libpng12. I went to Yast and did just that.

Now it starts and runs by double clicking on the file name in dolphin just like Fulvio Senore, the developer, said it should. I will send him an email so he can help other ignorant users like me.

I haven’t had time to go through the learning process to use the application yet. If everything works OK, i will probably just leave the download differences alone as one of the mysteries of the universe. I am curious though about how the tar.gz can be that different over the course of just two days. Maybe the developer is still making changes? Any other ideas?

Than you both - malcomlewis and jcmacdaniel3 - for putting me on the right track once again. I wish I was more of an expert instead of a full-time end-user. I will try to help other users by writing a review of how this software works from an end-user perspective. Maybe I can contribute something that way.


Happy to be of assistance and very happy to hear you got it running.

Thank You,

Just to tidy up and bring the thread to a conclusion, here is the email reply from the VVV developer concerning the different downloads:

*I really don’t know the reason for those differences, but it looks like
they are harmless. Archive usually files have a way to detect if some
part of the file has been lost. Moreover a corrupted distribution file
almost certainly would not run.

So if your program is running without errors it should be ok.



Hi, I’m trying to start Vitual Volumes View with Ubuntu 14.04 LTS 32bit with libnpg12-0 installed but I have a problem similar to the one that you described. When I try to execute the script vvv-start.sh from Konsole I always get the message “permession denied” and “bad interpreter”, also with command “sudo” at the beginning of the string.

How can I solve it? I have few experience using Ubuntu.

Thank you very much, best regards