Vuze crashing right after starting

I just reinstalled my entire OpenSUSE.

Then I tried to start Vuze, but it crashes immediately after startup. I started it manually from a terminal, and copied the resulting text from the terminal here:

Starting Azureus...
Suitable java version found [java = openjdk 1.8.0_40]
Configuring environment...
Java exec found in PATH. Verifying...
Loading Azureus:
java -Xmx256m -cp "./Azureus2.jar:./swt.jar" -Djava.library.path="/opt/VUZE" -Dazureus.install.path="/opt/VUZE" -Dazureus.script="/opt/VUZE/vuze" -Dazureus.script.version=4 org.gudy.azureus2.ui.swt.Main 
file:/usr/local/opt/VUZE/Azureus2.jar ; file:/usr/local/opt/VUZE/swt.jar ; file:/usr/local/opt/VUZE/
changeLocale: *Default Language* != English (United States). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
UIFunctions/ImageLoad took 0ms
new shell took 100ms
new shell setup took 25ms
skin init took 51ms
MainMenu init took 50ms
pre skin widgets init took 25ms
skin widgets (1/2) init took 201ms
skin widgets (2/2) init took 25ms
pre SWTInstance init took 0ms
Init Core Columns took 75ms
SWTInstance init took 0ms
shell.layout took 125ms
---------SHOWN AT 1436542907494;1524ms
---------DONE DISPATCH AT 1436542908124;2154ms
---------READY AT 1436542908124;2154ms
shell.open took 630ms
processStartupDMS took 0ms
postPluginSetup init took 0ms
Locale Initializing took 25ms
com.vuze.plugins.azlocprov.internat.Messages: no default resource bundle
Core Initializing took 414ms
Analysing /tmp/hs_err_pid21027.log
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f29afd26785, pid=21107, tid=139819405051648
#
# JRE version: OpenJDK Runtime Environment (8.0_40-b10) (build 1.8.0_40-b10)
# Java VM: OpenJDK 64-Bit Server VM (25.40-b14 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libjavascriptcoregtk-1.0.so.0+0x55b785]  JSC::RegExpCache::lookupOrCreate(WTF::String const&, JSC::RegExpFlags)+0xb5
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid21107.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Exit from Azureus complete
No shutdown tasks to do
Azureus TERMINATED.

The log file mentioned (/tmp/hs_err_pid21107.log) is pretty long, so if you need to see it look here: ftp://behne.ddns.net/Vuze.crashes/

It worked just fine before I reinstalled the OS. Whatever is causing this crash is way over my head, so any help solving it would be appreciated. If you need more info just tell me what command to type, and I’ll post the results. Thanks!

Your logifle suggests that your openJDK 8 may be related to a failure to build a component.
Are you sure your previous OS (before rebuild) was also running openJDK 8?

There’s no useful information <why> you experienced your Java error, so

  • If you haven’t already updated your system after re-building, do so… It’s critical to run at least once after a system build
zypper up
  • You can try a different version of openJDK (I haven’t checked, query your openSUSE repository for “openjdk”
  • You can try an Oracle JDK or JRE instead of openJDK.

TSU

Thanks tsu2! That fixed it!
Problem solved!!! lol!