vulkan dxvk problem

so through trial and error i have discovered that my second graphics card disappears from my entire os until i reboot only when i run something with dxvk or vulkan i can run any emulator just fine in opengl but te second i even set up like dolphin-emu or ppsspp to run in vulkan bam my second graphics card disappears should i make a bug report? or dose anyone know how to fix it. i have an asus rog strix g15 amd advantage edition laptop with ad ryzen 9 5900HX and a rx6800m gpu.

ok so if u run vulkainfo my gpu shows up as llvmpipe. also if i run dolphin-emu with terminal the first launch of it my second gpu shows up and runs fine then when i exit and relaunch anything with vulkan i get no errors in terminal but no second gpu also. and the FIRST launch of something using vulkan i do get a message that reads.

WARNING: radv is not a conformant vulkan implementation, testing use only.



well i tried this on my boot options did not help also tried renaming a vilkan .json as recommended on google now i suspect it may be vulkan mesa but no way to tell

radeon.si_support=0 amdgpu.si_support=1

well i just re installed opensuse tumbleweed and well nothing changed still the same problem so i assume its mesa thanks but still not sure

Hi
What is your GPU, you should not need any switches, if an SI card GCN 1.0, then it only works with radeon?

I see both my cards fine…


Layers: count = 1
=================
VK_LAYER_NV_optimus (NVIDIA Optimus layer) Vulkan version 1.2.175, layer version 1:
        Layer Extensions: count = 0
        Devices: count = 2
                GPU id = 0 (AMD RADV POLARIS12 (ACO))
                Layer-Device Extensions: count = 0

                GPU id = 1 (NVIDIA GeForce GT 1030)
                Layer-Device Extensions: count = 0

i have a ryzen 9 5900HX cpu and whatever apu is in it i think reanor but my main gpu or well the one that disappears is the amd rx6800m or flounder

Hi
I would remove those lines from grub kernel options, I suspect APU is Renoir and the other a newer NAVI (22?). If you add the following kernel boot option;


amdgpu.exp_hw_support=1

I suspect a bug report may be needed…

i tried the command u gave me on bootloader and nope same problem same error. and how would i go about reporting this bug properly and who do i report it too.

Hi
Against the kernel, read here: openSUSE:Bugreport kernel - openSUSE Wiki report here: openSUSE:Submitting bug reports - openSUSE

Post back the bug report link as well :wink:

https://bugzilla.opensuse.org/show_bug.cgi?id=1188657

i think i did this right lol

Hi
Looks good to me to get things kicked off :slight_smile:

I would suggest adding the output from dmidecode and /usr/sbin/lspci -nnk