VSFTPD not the primairy ftp server.

Hey Guys,

i’m having trouble setting up my vsftpd server.
here’s the problem:
i’ve installed vsftpd on opensuse 11 with openssl.
i am able to connect trough tls: sftp://localhost

but even with chroot_users set to YES i’m directed tot the main file system /

when i stop the vsftpd service i’m still able to ftp to the file system, this means there is another ftp server active. with system-monitor i found gvfsd-sftp, my question is: is this an ftp server and can i shut it down to let vsftpd be the primairy ftp server?

Arnold Nijboer

Alright… figured something out…

it’s the standard sftp service from openssh.

i’ve now edited the sshd_config. with the right subsystem: vsftpd

but when i connect with the ftp server i get the error:
ssh-program suddenly stopped.

the line i entered was:
Subsystem vsftpd /usr/sbin/vsftpd

somebody throw me a lifeline please…


vsftpd will not work with sshd like that. Only sftp works in that option. And sftp is unrelated to the normal ftp service.

What is it you are trying to do, set up ftp over SSL? This is done by configuring vsftpd and not touching sshd at all.

wel thanks for the reply,

indeed what i’m trying to do is to get vsftpd with tsl.

but when i configure vsftpd the ssh deamon is taking over,
and the configuration of vsftpd goes out the window so to speak.

especially the chroot function is a problem, and that’s the option i do need from vsftpd.

can you help me with this?


And again the problem is with the user :frowning:
i’m connecting with the server through nautilus:
and it should be ftps://… but nautilus can’t handle that:’(

what application could i use in stead of nautilus??
and is it possible to disable the sshd without losing other functions. because this is a serious leak at this point for me.


You could look at using gFTP :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1:39, 1 user, load average: 0.08, 0.17, 0.14
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

Thanks for the suggestion.
in the meanwhile i’ve installed filezilla.

but i’m now getting an “ECONNABORTED - Connection aborted”
after some research i found that it’s an error in the closing flag from the tls from vsftpd. some say it’s solved with vsftpd 2.0.7

but my up-to-date opensuse 11 does only have 2.0.6-25.2
while 2.0.7 is out for a few months now!

any suggestions??

There is a 2.0.7 version here;

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 2:12, 1 user, load average: 1.37, 0.92, 0.42
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

Thanks dude…

That made my day <:)<:)

completely up and running vsftp + tls trough filezilla lol!

Just one question remains,
is it possible to shut down sshd without losing other functions
on my server??

Why not keep it running for remote access (cli etc)? If it’s security
your concerned about move the daemon to another port eg 10222 22222 etc
vi the sshd_config file.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 3:02, 1 user, load average: 0.76, 0.42, 0.21
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

no need for remote excess…
server is at home, with a kvm-switch connected to a monitor :wink:
so i’m nailing all ports that don’t need to be open very shut!

so thanks for the help. now the next project… apache2 with tls rotfl!