VPN PPTP not working with new Network-Manager 0.9.8.8-13 and ppp 2.4.7

Hallo,

recently, there were updates of NetworkManager and ppp. In consequence, I cannot connect to a VPN-Server (PPTP) anymore.
Falling back to the previous versions solves the problem.

It was similiar some months ago, after an update of some Network programs VPN with PPTP didn’t work anymore.
That could then be solved by manually loading the module nf_conntrack_pptp.

Could someone improve or repair the packages or give me some advice, how to setup the commection with the new packages?
Thank you.

Kind regards,
Jörg

See also https://forums.opensuse.org/showthread.php/511394-Problem-installing-openSUSE-2015-827?p=2741100#post2741100

It looks as if that NetworkManager update was broken. It needs to be reported as a bug.

Guys,
I have this problem.
https://bugzilla.opensuse.org/show_bug.cgi?id=957961

It has broken my ability to work.

Workaround by backing out the network manager update breaks a lot of stuff apparently (I will maybe post a listing later if you like).

Living with this is not an option: I’m looking for the “best” workaround and a prompt patch.

Thanks,
Let me know if I can do some testing.
Adam.

The problem has been solved with the release of NetworkManager-pptp 0.9.8.4-3.1. :slight_smile:

However, I have to load one module by hand after each reboot to establish a PPTP connection
with NetworkManger:

modprobe nf_conntrack_pptp

So I recommend trying this, if your connection does not build up even with the new NetworkManager-pptp package.
Jörg

This worked for me under OpenSuse 13.2, probably it will work with 13.1, I will test later.

You can probably automate that with an entry in “modules-load.d”. Check the man page for details.