vpn bug

If I start my vpn connection with the command vpnc (as root), I am able to ping servers, access my mounted files from the vpn, but I can’t browse the internet, can’t write files on my mounted HD.

If I start vpn using the networkmanager it works fine, but I hate the networkmanager since it doesnt have an option to shut down the vpn connection (and I just dont like using it in general).

Is there any way I can get my vpn to work with the vpnc command?

I just noticed that I can connect to the vpn if I chose “User Controlled with NetworkManager” as network setup method instead of “Traditional Method with ifup”.

I still would apreciate if someone would post a way to have vpnc work with ifup.