Volume up/down/mute non responsive or delayed. Never had problem until recent updates

Suse 11.4 / x32 / Dell Vostro 1500. My volume adjustments always worked perfectly no matter where I did them. Now after doing many updates over the past month, I have a problem where “at times” the volume is non responsive to the buttons on my laptop, or the speaker Icon slider. If I go into port audio sound control, then I can adjust it. Definitely a bug. It would be great to fix it.


OK, I tried installing the previous kernel version, and tried reconfiguring the sound card. Both made no difference. The problem is definitely KMIX. I can adjust the volume everywhere(ALL APPLICATIONS/pulse audio) but not with KMIX. Sometime KMIX does work, but other times it does nothing at all, or the action can be delayed for seconds to a minute. What can I do about kmix? Really annoying issue that I never had before.


OK. I solved the problem. I deleted KMIX with Yast, then did an “updatedb” in terminal and looked for any remaining files with kmix in them and deleted them all. I then re-installed KMIX. Issue resolved.

I used to run into this behaviour from time to time in Opensuse 11.4

you can see the discussion here and how to fix it up when it does appear.


I have never seen it present itself in either 12.1 or 12.2 so it does appear to have been fixed