volume mixer present at boot - how to make it go away

I have at least two programs/services that start up when I log in.

  1. The volume icon appears, as normal, in the tray, but the mixer program also is running on the desktop. If I do a File/Quit on the mixer, the volume icon disappears from the tray, but then both show up on next boot. (I only want the volume icon in the systray)

  2. I thought I’d try HP’s “hplip” but it didn’t recognize my network printer. So I don’t need or use it, but since that one time where I tried it, it always has an icon in the systray. I right-click and quit it, but it shows up at next boot.

I tried going to Yast/System Services, and hplip is listed as “No*” (not enabled but running). And I don’t know where to begin for getting the volume icon to stay on the desktop without having the mixer window also

Your help is appreciated.

Mixer icon: what DE are you using, KDE3, KDE 4, Gnome, XFCE, etc? If KDE4, which version?

hplip: You could try to uninstall hplip from yast’s software manager.