'Volume could not be mounted' [SMB]

Hi!

I shared a few directories using samba which can be detected with XP or OSX over the network. However, when I try mount those folders this error occurs (OSX): ‘Volume X could not be mounted’.

I checked that smb as wells as xinetd is running and that the firewall ports are open (also tried deactivating the firewall with no success).

Would appreciate any help.

Phong

I do not know how your Samba is setup but I have an example post you might want to look at:

Samba SMB file sharing in openSUSE 11.2 - openSUSE Forums

When I go to a Windows XP machine and map a drive to my Samba setup, it works just fine. I do not have OSX to try, but it stands to reason if XP will not work neither will OSX. Look at my post and see if modifications to your Samba setup might help.

Thank You,

Thank you jdmcdaniel,

I’ll take a look on it. My setup was configured pretty easily with just right-clicking on the folder and within the properties activated sharing. But I’ll take a look into your guide first!

Thanks a lot!

Phong

Excellent guide! Very clearly described. Unfortunately I still have the same problem. Any ideas?

Thanks,

Phong

I have three questions:

  1. The share that fails to mount in OSX, does it also fail to mount in XP?
  2. Please post here the contents of the file smb.conf
  3. Please post here the return you get when you execute this command:
sudo pdbedit -L

>> 1. The share that fails to mount in OSX, does it also fail to mount in XP?

Yes, it does.

>> 2. Please post here the contents of the file smb.conf

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2009-10-27
[global]
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = Yes
add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
domain master = No
security = share
usershare max shares = 100
passdb backend = smbpasswd
server string = Phong linux workstation
hosts allow = 192.168.50.0/255.255.255.0, 127.0.0.1
winbind gid = 10000-20000
winbind uid = 10000-20000
workgroup name = WORKGROUP

[home]
comment = All users
path = /home/
acl check permissions = No
inherit acls = yes
profile acls = yes
veto files = /aquota.user/groups/shares/
valid users = phong

[public]
path = /home/quattro-xfs/PUBLIC/
guest ok = yes
read only = no
valid users = phong

[TEST]
path = /home/quattro-xfs/TEST/
guest ok = yes
valid users = caro
read only = no

3: Please post here the return you get when you execute this command: sudo pdbedit -L

Unknown parameter encountered: "workgroup name"
Ignoring unknown parameter "workgroup name"
phong:1000:Phong

I think you need to look back at my example smb.conf file. Here is the first two lines in my file:

workgroup = WINDOWSNT
netbios name = LINUXMASTER

“Workgroup” is not “workgroup name” as yours shows. Also why not put these important items at the top of the list instead of the bottom?

On Fri March 26 2010 08:36 pm, jdmcdaniel3 wrote:

>
> I think you need to look back at my example smb.conf file. Here is the
> first two lines in my file:
>
> workgroup = WINDOWSNT
> netbios name = LINUXMASTER
>
> “Workgroup” is not “workgroup name” as yours shows. Also why not put
> these important items at the top of the list instead of the bottom?
>
NhatPhongTran;

It might be helpful to look over this Howto by Swerdna:
http://opensuse.swerdna.org/suselanprimer.html

As jdmcdaniel3 noted the last line should be:


workgroup = WORKGROUP

Assuming you used WORKGROUP for the name of your workgroup on the other
machines.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

In addition to the comments of venzkep and jdmcdaniel3, I suspect you cant mount the shares for the following reasons (perhaps, just perhaps):

The share [home] belongs to Linux user:group = root:root which is not a useful permissions arrangement for Samba.

The share [public] seems to belong to user:group quattro-xfs:users, but the only valid user is phong, which seems to be a bit of a contradiction. Also, you’ve made it accessible to guests and that makes it a bit more confusing in light of the “valid user” parameter and the ownership.

The share [TEST] has similar inconsistencies to the share [public] but also you’ve designated a valid suer named caro who is not even in the Samba user database, giving rise to an additional question mark.

But all of this gets a bit more mixed up when you designate “security = share” in the [global] stanza. Probably you should avoid “share” security.

I recommend you follow venzkep’s suggestion and work through the Samba LAN Primer.