Volume control

Got a bit of a problem with my volume control in Opensuse 11.2. Haven’t really looked into it too much before as it is not a big issue.

With teh volume control (kmix)the master volume slider does absolutely nothing. It seems the master volume control for me is the pcm slider.
If I go into the sound control module in yast2 the same issue is present - master slider does nothing.

This seems to be an error as I cannot find any way to assign volume control to the master slider - which is a little inconvenient because I have to open the kmix window to change volume rather than just clicking on the speaker icon in the tray that pops up the master slider (which for me does nothing).

Sound card (as showing in Opensuse) is intel ICH6 (with AD1981B)

Have you selected the Master Channel or PCM Channel?

I’m not quite sure I understand the question. Selected where? In kmix I have both master and pcm selected. Unchecking master simply removes that slider from the kmix window - but if you click on th espeaker icon in teh tray it still pops up a single slider for master.

Right click kmix
select master channel
which radio button is selected

aha! - wasn’t aware of that option. Thank you.

:):)I’m smiling…

I resurrecting this old thread as a caution. I noted this today on a Thinkwiki site for the AD1981B:

A bug was introduced in the 2.6.20 kernel (between the rc1 and rc2 releases) which causes the sound to stop working after hibernation. Rebooting does not seem to fix the problem. A quick work-around is to do a suspend-to-ram, and then wake the machine up. This issue is chronicled in this bug report on Launchpad.net: The fix changing HIBERNATE_MODE=shutdown to HIBERNATE_MODE=platform in /etc/default/acpi-support worked very well. I don’t know if it possibly could introduce other bugs or if it’s a true fix.


Changing HIBERNATE_MODE=shutdown to HIBERNATE_MODE=platform in /etc/default/acpi-support seems to be solving this issue for many users. Confirmed to work with: X31, T43p
Even thou that dates back to year 2007/2008, its not clear to me that Ubuntu ever forwarded the fix upstream.