Volume control configuration problem ? - ICH5 and Kmixer

Can’t seem to get control of sound with desktop volume control. When I click on the desktop icon Mixer/Master volume/ Mute pops up but the only way to change the volume or mute is to open the Mixer (ICH5 panel appears) and change with PCM slider. ICH5 has capture checked and I can’t seem to uncheck it. Master volume control has no effect on anything. Headphone volume works with it’s slider related to the PCM volume setting when headphones are connected. When haead phones are not connected PCM and Headphon volume control speaker volume. In Kmxer configuration Master, PCM, CD, Headphone, and Headphone Jack-sense are checked.

:~> uname -a
Linux linux-s4nv 2.6.31.8-0.1-default #1 SMP 2009-12-15 23:55:40 +0100 i686 i686 i386 GNU/Linux

:~> cat /etc/SuSE-release
openSUSE 11.2 (i586)
VERSION = 11.2

:~> lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
knotify4 3361 dana 12u CHR 116,9 0t0 4698 /dev/snd/controlC0
kmix 3383 dana 10u CHR 116,9 0t0 4698 /dev/snd/controlC0

:~> /etc/modprobe.d/50-sound.conf
bash: /etc/modprobe.d/50-sound.conf: Permission denied

:~> sudo /etc/modprobe.d/50-sound.conf
root’s password:
sudo: /etc/modprobe.d/50-sound.conf: command not found

copied and paste here contents root/etc/modprobe.d/50-sound.conf:
options snd slots=snd-intel8x0

W60f.KFP4zhAxwiC:d330 uT

alias snd-card-0 snd-intel8x0

:~> rpm -qa | grep alsa:
alsa-utils-1.0.21-3.1.i586
alsa-plugins-pulse-1.0.21-3.3.i586
alsa-plugins-1.0.21-3.3.i586
alsa-oss-1.0.17-25.2.i586
alsa-1.0.21-3.2.i586
alsa-devel-1.0.21-3.2.i586

After yast update:
:~> rpm -qa | grep alsa:
alsa-utils-1.0.21-3.1.i586
alsa-oss-1.0.17-25.2.i586dana@linux-s4nv:~> cat /etc/modprobe.d/sound
cat: /etc/modprobe.d/sound: No such file or directory
alsa-plugins-pulse-1.0.21-3.3.i586
alsa-devel-1.0.21-3.2.i586
alsa-docs-1.0.21-3.2.noarch
alsa-plugins-1.0.21-3.3.i586
alsa-1.0.21-3.2.i586

After update alsa/multimedia ? repo:
:~> rpm -qa | grep alsa:
alsa-utils-1.0.21-3.1.i586
alsa-oss-1.0.17-25.2.i586
alsa-driver-kmp-default-1.0.22.1.20100122_2.6.31.8_0.1-1.1.i586
alsa-plugins-pulse-1.0.21-3.3.i586
alsa-devel-1.0.21-3.2.i586
alsa-docs-1.0.21-3.2.noarch
alsa-plugins-1.0.21-3.3.i586
alsa-1.0.21-3.2.i586

:~> rpm -qa | grep pulse:
pulseaudio-module-zeroconf-0.9.19-2.3.i586
libpulse-devel-0.9.19-2.3.i586
pulseaudio-module-gconf-0.9.19-2.3.i586
pulseaudio-module-bluetooth-0.9.19-2.3.i586
libxine1-pulse-1.1.17-1.pm.25.1.i586
libpulse0-0.9.19-2.3.i586
pulseaudio-0.9.19-2.3.i586
libpulse-mainloop-glib0-0.9.19-2.3.i586
pulseaudio-module-x11-0.9.19-2.3.i586
alsa-plugins-pulse-1.0.21-3.3.i586
libpulse-browse0-0.9.19-2.3.i586
pulseaudio-module-lirc-0.9.19-2.3.i586
pulseaudio-utils-0.9.19-2.3.i586

:~> cat /proc/asound/modules:
0 snd_intel8x0
:~> cat /proc/asound/cards
0 [ICH5 ]: ICH4 - Intel ICH5
Intel ICH5 with AD1981B at irq 17

of ADCs: 2

DAC: 2

ADC DNR (dB): 85dB

Compliant: 2.3

DAC DNR (dB): 90dB

Number of Channels:2

/usr/sbin/alsa-info.sh:
Large file can provide url or copy if needed.

:~> cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.20.

:~> speaker-test -c2 -l5 -twav:
speaker-test 1.0.21
Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
1 - Front Right
Time per period = 2.860683
0 - Front Left
1 - Front Right
Time per period = 3.008253
0 - Front Left
1 - Front Right
Time per period = 3.008171
0 - Front Left
1 - Front Right
Time per period = 3.008278
0 - Front Left
1 - Front Right
Time per period = 3.008175

If you update the alsa-driver-kmp-default and you observe strange effects, then IMHO you should update the remainder of the alsa apps from the repository here:

http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.2/

… I don’t know if you think you did you update them, … but it does not matter as you have not updated them. Those are the old OSS versions.

To be consistent with the alsa-driver-kmp-default, you should update your alsa apps (highlighted in red) with versions from the multimedia repository. If you need help doing this with YaST then advise.

Note: Other than alsa-driver-kmp-default, do NOT add extra rpms, … just update.

Yup. You are right on the money and yes I did think I had updated.Went to Yast added the multimedia repo with low priority and updated. Should I disable the repo after update or leave it enabled and set a relative priority? I think I may have some more updating to do elsewhere now that I think about it. Thanks again oldcpu. SOLVED

These tend to be very cutting edge alsa applications, and on more than one occasion they have broken sound (as opposed to fix).

Hence I recommend you disable the repos.