Vodafone K3805-Z dongle

I have 12.1 installed on my laptop and it seems the dongle connects as i get an ip address assinged, (10., numbers) However when i try to connect to the web i get any inbound of outbound data and it fails to connect. I tried the firewall to no avail. I can ping my own ip address but when i try to ping vodafone dns servers it comes back unreachable. Any idea folk, Cheers Mal

With your device connected, can we see the output of

/sbin/ifconfig
cat /etc/resolv.conf
/sbin/route -n

mal@linux-1e6u:~> /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:1E:8C:E6:DC:D1
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:213 errors:0 dropped:0 overruns:0 frame:0
TX packets:213 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:15997 (15.6 Kb) TX bytes:15997 (15.6 Kb)

usb0 Link encap:Ethernet HWaddr 02:6A:C8:65:C9:A9
inet addr:10.180.119.81 Bcast:10.180.119.81 Mask:255.255.255.255
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:3 dropped:0 overruns:0 frame:0
TX packets:85 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:6972 (6.8 Kb)

mal@linux-1e6u:~> /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 usb0

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search site
nameserver 10.206.65.68
nameserver 10.203.65.68

I got it to connect after changing different settings, the connection lasted about 5 minutes and then stopped

Still not having any luck at all with this, The only time i got it to connect correctly was when i changed the IP4 settings to manual and inputed the addresses as per the vodafone website. Strange this is ,if i try to reconnect it assigs another IP address and wont connect, sometimes it does assign the IP address i inputed but i still dont get any traffic. Thought i would be cheeky and bump the thread hoping for some ideas, Cheers Mal

I’m not sure about the solution, apart from manually assigning IP address and gateway. You can add the DNS manually as well.

The routing table shows no gateway assigned

mal@linux-1e6u:~> /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 usb0

I would have expected something more like

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.180.119.0     0.0.0.0         255.255.255.255 U     2      0        0 usb0
0.0.0.0         10.180.119.1     0.0.0.0         UG    0      0        0 usb0

Hi,

I also have the same problem. I’m using opensuse 12.1 and the Vodafone 3G dongle (K-3805-Z) is recognized. The networkmanager shows it and registers it in Vodafone (I get public IP, the resolv.conf is updated with the DNS IP), but my routing table keeps clean (without any rule). I’ve tried to add the above rules but it didn’t work either.
Can please anyone help me ?

Thanks in advance,

José Andrade

I’ve tried to add the above rules but it didn’t work either.

I hope you didn’t use the IP addresses I used - they were just examples of what I’d expect for internet connectivity.

You can manually assign a gateway with

route add default gw xx.yy.zz.uu usb0

where xx.yy.zz.uu is the gateway IP address.

Just a bit more info i found. Connected through windows and found out that the vodafone dns , dhcp, and gateway server addresses changed. So now i get assinged another IP address. If trhis is the case then i dont think i will ever connect through my suse box. Why would they change the server addresses?

I don’t know how they assign the address space, but it is likely that the probably have a number of subnets operating, and therefore the gateway will change as well. The DNS can be manually assigned, so that is not such a problem.

It might be useful to examine /var/log/messages to determine what is failing during the connection process.

If one googles ‘k3805 network manager’ and similar, there seems to be a lot of trouble with these devices reported, (across various distros).

You options may include

  1. Searching for exciting bug reports, and filing a new bug report if necessary.

  2. Try using the ‘wvdial’ CLI utility. This involves creating a /etc/wvdial.conf first, and executing wvdial to connect. (I’ll leave that to you to research further).

  3. Some users have has success using the sakis3g script, but this depends on the nature of the fault, and whether it is simply a ‘vodafone’ issue eg SIM card activation etc.

Sakis3G installation - Sakis3G wiki

Sakis3G as a udev rule

Thank Deano,

However for some strange reason, the Vodafone DNS servers keep changing addresses, I have added these all to no avail

From what I understood, your real problem was the lack of a default route (for internet connectivity). That needed to be solved first.

THanks for all your help deano, , i give up now, i even posted on the vodafone forum and even there tech team couldnt help. There must be a mobile dongle out there that works with suse, Anyone?

I’ve had good experiences with the E-series devices (eg E160, E220). I don’t know if they’re still current.

I reported on a much older device that my wife purchased on ebay in this blog entry: Looking for mobile router (or mobile 3G compatible) router … - Blogs - openSUSE Forums

Fortunately for me it ‘just worked’.