Vodafone - connected, but no internet?


I’m using SuSE 11.3. I have installed this betavine stuff with which I can use my Vodafone mobile connect usb device. (vodafone-mobile-connect-2.10.01-1.noarch.rpm + dependencies.) I was able to get it to run, it can connect, I can even send text messages (SMS) with it.

However, if I try to use the internet, the system behaves as it wasn’t connected to it at all. ping doesn’t see anything, neither does firefox etc. I have turned off all proxy and firewall settings.

I suppose I should tell Linux to use this connection for the internet, but how? Do I have to configure something with NetworkManager?


have a read through a couple of these threads

Unable to use GPRS dial up connection

and start from post #4 deano_ferrari

Zoom USB external modem install failure

it often seems worth quoting what

cat /etc/resolv.conf

After having turned off Network Manager, as suggested in the article you’ve pointed out:

(as root)

cat /etc/resolv.conf:

lots of remark text


(which are exactly the name servers of Vodafone Hungary that I have entered in Betavine’s connectivity software)

/sbin/route -n

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface UH 0 0 0 ppp0 U 0 0 0 lo U 0 0 0 ppp0

I don’t know what this means, but those lots of zeros don’t look very promising…

I’ve also tried

traceroute Name or service not known

No net at all still…

… and the output of /sbin/route -n in a bit more readable format:

# /sbin/route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface UH    0      0        0 ppp0       U     0      0        0 lo         U     0      0        0 ppp0 

These look kinda strange… based on a quick test this notation is not working neither in /etc/resolv.conf nor on the command line, as you point that out as well. The counter test was also conclusive: getting rid of the leading "0"s mande the name resolving problem go away. You also might have other issues besides this, but I’d try to remedy this first. Your /etc/resolv.conf should look similar to this:


The interesting thing is how these addresses in this notation got into /etc/resolv.conf. Did you put that in manually, or did pppd (or some other tool) during the initiation of the connection?
Manually editing the /etc/resolv.conf is not recommended, especially if one uses multiple interfaces (wired, wireless, dial-up etc…)

Thanks for the hint, that was exactly the problem.

It was me personally who entered those name server ip-numbers in the setup of the software, wich were free text. I got those addresses from the Vodafone help line. I think you can enter the numbers like that in windows, it’s even easier to type them in, because after 3 characters the input control automatically takes you to the next triplets. Anyway, the connection software entered those addresses into /etc/resolv.conf, that’s how they ended up there.

Anyway, now without the superfluous zeros it works completely fine. Why don’t I just copy in the URL of the software which is dead easy to set up (once you’ve resolved all the necessary dependencies, for which you need the internet, however!), it’s not commercial stuff after all:

Betavine - SuSE Linux Drivers

Thanks for the help, I’m very happy that it works!


How can I mark this thread as solved? (Since it is.)

agostonbejo wrote:
> How can I mark this thread as solved?

you can’t…if you are interested in why, there are several threads on
that subject in the forums discussing the forums, see:

CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]