Vncserver black screen issue

Hi everyone,

I am trying to access my machine through VNC. The distro that I am using is the SLES 15.1 and is hosted under azure services. The deployed version is the server one and therefore I added the GNOME afterwards. Everything worked fine. Until I try to run the vncserver.

If I do: sudo vncserver :1 I am able to see the gnome interface as expected from the vnc client. However if I execute vncserver :1 as regular user I see a black screen on the vnc client.

I already tried multiple xstartup files, but without success.

Does anyone know the reason for this to happen and how to fix it?

Thank you

Modern GNOME does not support more than one concurrent session for the same user which may be the reason for the observed behavior. Otherwise you are better off asking on the correct forums https://forums.rancher.com/ This forum is for openSUSE, not for SLES.

I’m not attempting to run them concurrently. When I run vncserver from the regular user alone, it doesn’t work, and I get a black screen.

Not sure if this is a SLES-related issue, but I’ll seek help from the other forum.

Thank you.

I figured it out!

DISPLAYMANAGER_REMOTE_ACCESS was initially set to “no,” but I changed it to “yes.”

It’s working now, and I hope this information can be beneficial for openSUSE users, even though I am using SLES.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.