VNC Server / XRDP keyboard problem


I’ve a problem trying to configure something to remote control my OpenSuse 11.3 machine.

First of all, let me say that I’ve got an Italian keyboard, so I have keys like à,è ecc…

I’ve tried XRDP 0.4.1 first, it worked well but after login, some keys (such 2,",7,/ ecc…) doesn’t work anymore.

So I decided to try VNC, but I have a similar problem: the ò,à,è and some other keys dosen’t work.

Everything works well if I log in from the pc.

This thing will drive me mad, any help would be appreciate…

Thank you


Some other things that can help:

-I must connect to my OpenSuse from a ThinClient, so I cannot use freeNX.
-My graphical enviroment is KDE.
-In Yast, Italian Keyboard is selected.

Thank you


Hungarian key-layout / hungarian letters (üóőúéáűí, and alt gr+letters, and some shift+numbers) doesn’t work yet.

The problem cause localization failure in xorg-x11-7.5-11.3.i586.

Try to x11vnc?
It works good.

install package :
| xorg-x11-Xvnc | VNC-kiszolgáló X Window rendszerhez

start from command line (for use auth): x11vnc -geometry 1024x740 -display :0 -http -rfbwait 600
man x11vnc :wink: