vnc no desktop

Dear all,

I’m trying to connect to my opensuse desktop via my Android phone using AndroidVNC. The goal is basically to have the phone as a remote desktop. When I start the VNC client, I get to the log in screen. As soon as I have entered my log in details, the connection breaks down saying
ECONNRESET (Connection reset by peer)
I have looked for the vnc server log but couldn’t find it. Any ideas highly appreciated…

thanks,
sirthid

Does anybody have an idea?

My understanding is that this error message means that the vnc server or some router or firewall in between the two devices disconnected you.

I just tested using androidvnc to take over the desktop of my openSUSE-12.2 KDE (laptop) over a common WLAN. This was a quick test with minimal security (ie no special password/security setup).

It worked for me. I tested this with my Asus Transformer TF101 tablet (10" display), and then with my 4" display Android (Chinese) Smart Phone (Zopo ZP-500+)

If you have not done so already, may I suggest you 1st attempt to take over your desktop via vnc from a normal computer, and become familiar with the vnc techniques, prior to trying to use an Android device for the same thing. The learning curve may be steep.

I find the mouse control with Androidvnc difficult, and hence I do not use this app nominally. I have no suggestions for any other app.

hi oldcpu,

many thanks for your reply. I didn’t really get to try out more until just now: I installed tightvnc on my Windows machine, and tried to connect from there, with basically the same behavior: I get to the login screen but as soon as I log in, the connection breaks down, saying “Failed to recv data from socket”.
The problem seems to be on the side of opensuse - do you know where I can find the log file for more details?

best,
sirthid

There are many log files in /var/log but as to a specific file/location I can not say off of the top of my head. I am currently on vaction in a Hotel room in Bangkok Thailand with Internet access speeds as slow or slower than dial up speed, and I do not have a PC with openSUSE with me (I am typing from an Android Tablet). So there is not much precise advice I can give.

Did you open up the appropriate ssh and vnc ports on your openSUSE firewall?

hi oldcpu,

many thanks for taking the trouble and helping me. I found an entry in /var/xinetd.log which might have something to do with vnc bu it doesn’t seem very helpful:


13/1/14@22:30:14: START: vnc1 from=192.168.2.108
13/1/14@22:30:44: EXIT: vnc1 status=0 duration=30(sec)

the firewall log has the following to say to this:


Jan 14 22:30:14 localhost kernel: 558.750968] SFW2-INext-ACC-TCP IN=eth0 OUT= MAC=xxx SRC=192.168.2.108 DST=192.168.2.104 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=43100 DF PROTO=TCP SPT=40851 DPT=5901 WINDOW=14600 RES=0x00 SYN URGP=0 OPT (020405B40402080A01B4BE7B0000000001030302)
Jan 14 22:30:38 localhost kernel: 581.987092] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=fe80:0000:0000:0000:0201:2eff:fe27:835c DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44

I can’t really make sense of this. VNC Server is on the list of the allowed services for the external zone, and the IP-adress is also set open for TCP and UDP. Any ideas?

best,
sirthid

Is ssh open in the firewall ?

Hi,

TCP is allowed for the IP-address, and VNC server is allowed for the external zone. Does SSH need anything else?
There isn’t any difference even when I shut down the firewall completely, however.

cheers!

I always have Secure Shell Server port open in my firewall, so I can’t knowledgeably comment if vnc will work properly without it enabled.

I live in Europe, and I maintain my mother’s openSUSE GNU/Linux PC in Canada using ssh and vnc. In fact I pipe the vnc connection through ssh for her desktop maintenance. I can’t contemplate using vnc without ssh open (I don’t know if ssh necessary for vnc).