VNC login openSUSE 12.1

i have a weird problem with opensuse and vnc

i upgraded to opensuse 12.1 and now i cannot vnc to my opensuse box
i tried all the things i came across while searching on google
i tried disabling/commenting ipv6 , changing resolution , dbus-launch
all what i get when i connect now is a black screen with the famous black x
any quick fixes?

The same VNC issue happens for opensuse 12.2. It seems the main concerns of opensuse developers are shifting gnome appearance towards Windows OS and breaking traditional Linux shortcuts and looks rather than improving its server services. FreeNX doesn’t work. VNC doesn’t work. Right mouse click doesn’t work. Workspace windows are not accessible. To get to another page, one needs to click on so many things. At startup, all user names are listed which is a threat to system security.
Back to the main topic, I also spent couple of days fixing VNC remote login in opensuse 12.2 with no hope. Tightvnc, tigervnc, realvnc, ultravnc all generate black screen. It seems there is something fundamentally wrong between VNC server and gnome desktop.