VNC - disconnecting

Good daytime.
I have install VNC service at OpenSuse.
When I try to connect to it from windows (using programs: TightVNC and RealVNC, free edition),

  1. connection establishes
  2. black-and-white X-windows screen shows
  3. open-sese logo chameleon shows
  4. connection is broken.
    What is a reason of this?
    Same reaction if when X-windows system (XFCE) on opensuse is run, is when I logout.

Maybe better if you use x11vnc to deliver your working X session to a client using VNC.

Excuse me, but what does it mean?
Start VNC server on Windows and configure opensuse to use it?

There’s a bug in openSUSE with KDE4 desktop, although it should not manifest itself when serving XFCE. Puzzle.

Question 1: Are you running vnc server from a running version of openSUSE with KDE4 Desktop?

And I found four places in Yast where I could start VNC plus from the command line is another method – so Question 2: how do you start your vnc server on openSUSE?

You say “I have install VNC service at OpenSuse”. There are two versions (two different RPMs) supplied with openSUSE. Question 3: Tell us which one by running this command in a console window: rpm -qa | grep vnc, and report the RPM back here.

Thank you for participation.

I don’t use KDE as desktop, only some libraries from it (I had install kvpnc and kinternet, so - required libraries is installed).
I use Xfce as desktop.

Info about vnc installation(terminal copy):
linux-uuv0:~ # rpm -qa | grep vnc

I launch VNC this way: Yast - Network Services - “Remote administration (VNC)” - select option “Enable remote administration”.
This is from installation time. The installation program asked me - Do I want to allow this, I check this option.
Checkbox “Open port in firewall” is also checked, but computer I try to connect from already is in internal zone, in firewall terminology.

I can’t see anything wrong with what you are doing. I followed your method exactly on my computer and had no problems. But I don’t have XFCE installed – I tried it with IceWM, Gnome & KDE4 and it was OK.

I wonder if it could be that you installed XFCE and it was not integrated into the xinetd process that drives vnc?

[when you click Remote Administration in Yast, that’s really a shortcut to switch on vnc in xinetd, have a look at Yast → Network Services → Network Services Xinetd, and you will see it is on for one of the six vnc entries. While this is a truly excellent form of server, it is not the more commonly used method of running vnc from the command line, and the xinetd method might not be enabled for use with XFCE].

Maybe you should try it in another desktop like IceWM which is one of the default Window managers.

Or perhaps vnc would run with XFCE if you activated it from the command line using this linked method.

But I’m really not sure of the advice I have given – simply some thoughts rather than some sure solutions.

I change xfce to icewm - no result, connection closed still.

I forgot to say - it may be important - when I try to connect to remote vnc-desktop from browser with java, it doesn’t close the connection same way as from exe-file. It connects, ask me for login-password, and then stops. Mouse pointer is moving correct, but no longer events.

I did not realise you were trying to connect by browser.

I am using KDE4 and you are not so this might not be relevant – but:

Server Side: I followed your method: Yast → Network Services → Remote Administration VNC → Allow Remote Administration + Open port in firewall.

Client Side (windows): Installed TightVNC, connect with Internet Explorer at http://ip.of.server:5801

Result: openSUSE login screen appears. On login the display closes and shows the error message “Network Error: remote side closed connection – Login Again button”

This is a bug for openSUSE 11 series.

Workaround: Before typing username+password in the login screen, open the Options button at top of display and select Cursor Shape Updates = Disable.
Then log on.

Does that help?

Excuse me for delay, I’ll answer soon.

I set “cursor updares” to disable.
Remote desktop halt up soon after boot, after login. Show me taskbar with menu, allow to open it, and halt.
Such a pity :frowning:
Lets close this topic, I think the God don’t want me to set it up correctly.

Such a pity. Maybe try RDP, that works for me (but then, so does VNC).

I know this is an old post, but I have same problem here and it’s finally solved.

If you want to vnc via browser (java), you must disable ‘cursor update’ option before you got disconnected. this can be tricky because you need to do it fast. If you don’t do it fast enough, then you’ll get disconnected. Too bad I dont know how to set that option before connecting to server.

If you use RealVNC, be sure to uncheck ‘Render cursor locally’ at Misc. tab on Option window. If you leave that option checked, sometime you will be able to login, but sometime you wont be able to login. (In my case, I cannot login with RealVNC after failed attemp to login with browser)

Hope that help, and please pardon my english.

I had the same problem with VNC but I went one step further. I ran a tail -f /var/log/messages on the vnc server that I wanted to connect to.

Then I went into the KDE desktop and did the following:

Clicked on application launchers (start if it were windows) | system | Desktop Sharing

Once the application opened, I selected three two items:

I clicked at the bottom where it said “Configure”, then clicked security on the left hand side.

My selections:

-> Allow uninvited connections
-> Allow remote connections control your desktop

Enter a password, click apply or ok.

Please be sure to just use the ip address when connecting to the desktop b/c it uses the default port 5900.

I think you are good to go from there, this is the client version and not the web version.