VNC connection screen does not update (vino)

Hello,

I’ve noticed that after updating opensuse to 11.2 from 11.1 vino is slighly different by its layout. Is there big changes in vino?

My problem is that when I connect to vnc (from windows with tightvnc viewer), it asks password normally, and let me log in, but when the screen has “rendered” from up to down, it doesn’t update it any more. It let me move the mouse, and if I test it locally from other computer in LAN, I see the mouse moving and text appearing when typing and windows moving when moving, but no changes in vnc viewer screen! I mean it doesn’t update the differences at all.

What could be the problem? I tried out realvnc as well, but it seems it is not in the viewer. Is it in vino? I have correct ports open and so, just like before. It worked in 11.1 but not in 11.2.

Any help? I use openSUSE 11.2, gnome, with vino.

Any one experienced with vnc/vino? Help would be highly appreciated.

OK, it seems that it doesn’t refresh with compiz on. Works fine without compiz enabled, like with metacity. But I love compiz… what is this bug? How this can be fixed?

I guess I have to tick compiz off when I need vnc… sorry for replying to myself but nobody seem to have this same issue.

Hi
Just use a xhost wrapper (remember to chmod 700 the script;


#!/bin/bash
xhost +
your vnc login command
Xnost -


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.39-0.3-default
up 3 days 4:01, 3 users, load average: 0.44, 0.20, 0.13
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Sorry, I have this little thing I forgot to mention. I use vnc mainly from windows (7 ultimate) (tightvnc viewer or real vnc viewer), and my vnc (vino) server is on opensuse 11.2. So no commands to connect vnc whatsoever. Only windows software graphical interface.

I have the same issue… someone has the procedure to fix it?
I appreciate that…

Sorry but it is crazy to think you can seriously run eye candy over a thin wire. Yes it can be done but you just eat bandwidth. Set up a user that has minimal eye candy and log into that account.

The thing is, I really could run eye candy perfectly well before openSUSE 11.2. Of course it works better with low-graphics-mode, and it ofc it’s crazy if you don’t have good connection.

But now I can’t run it at all (or can, but it only shows you the picture without refreshing any changes I make), not in low-mode, not with anything. Seems odd that there is no fix for this, because this is obviously bug in opensuse 11.2/vino.