VNC closes/crashes after log in

I upgrade from 12.2 to 12.3 and now vnc isn’t working anymore. My system: Opensuse 12.3 64bit gnome. Firewall is disabled.

Maybe someone is willing to help me solving this problem. I’ve tried for a few days but did not make any progress.

I can make a connection with my VNC client of with the web interface, i see the login screen of opensuse but as soon as i enter my name and password the application closes or crashes. The webinterface gives me: Network error: remote side closed connection.

Link:- https://forums.opensuse.org/blogs/jdmcdaniel3/how-use-vnc-remmina-remote-control-opensuse-12-3-kde-desktop-132/

Thanks, i re-checked but all my settings should be ok.

But I still have this problem. The VNC connection to my Opensuse 12.3 is made. I can see the log-in screen but as soon as i log in the connection fails. Could it be an authorisation thing? what should i look for in the logs?

I have same issue. openSUSE Tumbleweed x86_64 with Gnome and KDE. GDM as display manager. GDM logon screen looks fine, I can to choose user and enter password, but after that connection terminate.

I found a couple of errors in /var/log/messages.

2013-03-27T14:02:09.948293+01:00 server dbus-daemon[1070]: dbus[1070]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.4" (uid=0 pid=2816 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.1835" (uid=0 pid=29274 comm="/usr/lib/gdm/gdm-simple-slave --display-id /org/gn")
2013-03-27T14:02:09.948705+01:00 server dbus[1070]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.4" (uid=0 pid=2816 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.1835" (uid=0 pid=29274 comm="/usr/lib/gdm/gdm-simple-slave --display-id /org/gn")
2013-03-27T14:02:10.682751+01:00 server systemd-logind[1041]: New session 710 of user gdm.
2013-03-27T14:02:10.739557+01:00 server gnome-session[29288]: WARNING: Session 'gdm-shell' runnable check failed: Child process exited with code 1
2013-03-27T14:02:10.881336+01:00 server polkitd[3121]: Registered Authentication Agent for unix-session:710 (system bus name :1.1844 [/usr/lib/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
2013-03-27T14:02:10.919819+01:00 server gdm-simple-greeter[29329]: Gtk-CRITICAL: gtk_style_context_set_path: assertion `priv->widget == NULL' failed
2013-03-27T14:02:10.964189+01:00 server dbus-daemon[1070]: dbus[1070]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.1843" (uid=115 pid=29329 comm="/usr/lib/gdm/gdm-simple-greeter ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.9" (uid=0 pid=3127 comm="/usr/sbin/console-kit-daemon --no-daemon ")
2013-03-27T14:02:10.964456+01:00 server dbus[1070]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.1843" (uid=115 pid=29329 comm="/usr/lib/gdm/gdm-simple-greeter ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.9" (uid=0 pid=3127 comm="/usr/sbin/console-kit-daemon --no-daemon ")
2013-03-27T14:02:11.268738+01:00 server gdm-simple-greeter[29329]: Gtk-CRITICAL: gtk_style_context_set_path: assertion `priv->widget == NULL' failed
2013-03-27T14:02:32.881787+01:00 server systemd-logind[1041]: New session 711 of user baba.
2013-03-27T14:02:32.897910+01:00 server gnome-session[29288]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed
2013-03-27T14:02:32.897926+01:00 server polkitd[3121]: Unregistered Authentication Agent for unix-session:710 (system bus name :1.1844, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
2013-03-27T14:02:32.900694+01:00 server systemd-logind[1041]: Removed session 711.
2013-03-27T14:02:33.000428+01:00 server gdm-simple-slave[29274]: GLib-GObject-CRITICAL: g_object_ref: assertion `object->ref_count > 0' failed
2013-03-27T14:02:33.000758+01:00 server gdm-simple-slave[29274]: GLib-GObject-CRITICAL: g_object_unref: assertion `object->ref_count > 0' failed

My messages after logon attempt:


Mar 25 09:46:48 desktop dbus[848]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.197" (uid=112 pid=6478 comm="/usr/lib/gdm/gdm-simple-greeter ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.8" (uid=0 pid=3060 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Mar 25 09:47:01 desktop systemd-logind[870]: New session 19 of user svalx.
Mar 25 09:47:01 desktop gnome-session[6432]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed
Mar 25 09:47:01 desktop polkitd[3054]: Unregistered Authentication Agent for unix-session:18 (system bus name :1.198, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale ru_RU.UTF-8) (disconnected from bus)
Mar 25 09:47:01 desktop systemd-logind[870]: Removed session 19.
Mar 25 09:47:01 desktop gdm-simple-slave[6417]: GLib-GObject-CRITICAL: g_object_ref: assertion `object->ref_count > 0' failed
Mar 25 09:47:01 desktop gdm-simple-slave[6417]: GLib-GObject-CRITICAL: g_object_unref: assertion `object->ref_count > 0' failed

Well it’s still not working for me. But i as an alternative i succesfully installed and ran tightvncserver.

Performance feels not as good as the build-in vnc server so i still hope that someone can help me with this.

Dear friends,

to solve this issue, you must do to the following procedure:

  1. Open /etc/xinetd.d/vnc file (make a backup copy before changes!)
  2. Go to the “service vnc1” session and look for the line containing server_args parameter
  3. On the parameter specified on step 2 and remove the “-once” (without quotation marks) parameter
  4. Save and quit the file
  5. Restart xinetd with the following command: rcxinetd restart

The file shall look like this:

service vnc1
{
socket_type = stream
protocol = tcp
wait = no
user = nobody
server = /usr/bin/Xvnc
server_args = -noreset -inetd -query localhost -geometry 1024x768 -depth 16
type = UNLISTED
port = 5901
}

This shall solve our problems connecting to openSuSE Remote Administration (VNC).

Best regards for everyone!

and if after this it asks for a password and authentication fails the next step is reading
Support | Enable VNC Password Authentication

extract:

Step 1

On the remote system open a terminal window and “su” to become the root user
(if not already logged in as root) then enter the command:

vncpasswd

Enter the passwords as prompted.

The first one for full remote access and the second for read-only access.
This will create and store the passwords in the file “/root/.vnc/passwd”.

Step 2

Open YaST and select Network Services–>Network Services (xinetd).
Scroll down the list to the “vnc1” selection and click on it then click on the “Edit” button.
Change the “User:” selection to “root” (the default setting is “nobody”).
Add the following text to the end of the “Server Arguments” line.
Be sure to include a space between the last entry and this new argument:
-rfbauth /root/.vnc/passwd

#end quote

Step 2 can be done editing /etc/xinetd.d/vnc

These instructions work for getting root access over VNC. I was successful connecting my Windows Laptop to my OpenSuse 13.1 Desktop via VNC Viewer.

What I really want to do though is connect to my actual user session that is already displayed on screen at the station. I want to be able to check on work in progress.

I tried editing the second steps using editing the Server Arguments to -rfbauth /home/$user/.vnc/passwd and of course selecting same user in the User list.

No love. It presents the KDE login screen but after the hard disk icon is displayed it goes to the blank vine desktop with no widgets or panels. I tried just leaving it there for a while but nothing.

How can I login to my active user session?

Was having the same exact issue with the vnc client disconnect after the disk icon solidifies on openSuse 13.1 x86_64. **rrsilvanet’s **advice cured the disconnect and the session stays open, I just can’t see it as the screen seems to hang on the login/splash screen and does not migrate to the KDE Desktop. I am dual screen with ATI video card and have recently migrated (clean install) from openSuse 12.2 using the fglrx-legacy video drivers in that build, now using the ‘free radeon’ drivers under 13.1 as fglrx-legacy is depreciated. To note, on the host machine screen 0, right after the disk icon solidifies the screen flashes (like a resolution switch) and the KDE desktop loads, I do not get to see the other icons load, nor is there a smooth fade to the KDE desktop… and this is where I’m loosing the vcn client. These icons do load however, and the fade transition does happen on the 2nd monitor, screen 1. I remember a similar ‘flicker’ between splash/login screen and KDE desktop in 12.2, but cured it ages ago and don’t remember how. Any help much appreciated!

Did you ever get a resolution on this issue?

I too can login authenticate but it just hangs on the default background.

Seems to be a problem with kdm multiple login … see at /var/log/messages like …
---- > kdm_config[28034]: Multiple occurrences of section [General] …
etc.

I tried to solve by a logout at the vnc server system … and it works with the remote vnc session :slight_smile:

No, that’s definitely not related to your problem.
Those warnings (those are no errors) are “normal” on openSUSE. They are caused by the way specific settings from /etc/sysconfig/ are added to the kdmrc.

But that should cause no problem whatsoever.

I cannot comment on your actual issue though.

Could you try different desktop environments at the login screen and see if you have the same issue with them? I have the same issue with 13.1 and I think it is something with the KDE environment.

I managed to get around this issue by disabling IPv6 in network settings in YaST, so there seems to be something fishy with the IPv6 and KDE combined.