VNC Broken in 11.1 KDE and GNOME

I installed the KDE version of 11.1 today and enabled remote administration. When I tried to connect to the machine, I got the login screen and entered my credentials, but the screen closed immediately after that.

Just for grins, I installed the GNOME version. With that version, I don’t even get the login screen. I can see that I’m connecting to the X server, but no login screen appears.

Any thoughts?

I confess I had not tested this yet.

So I installed x11vnc on my openSUSE-11.1 PC running kde-3.5.10 (tightvnc was already installed) and then from my openSUSE-10.3 PC, I started a vnc server session on my openSUSE-11.1 PC. No problem. I had previously opened the 11.1 PC firewall for ssh and vnc.

Perhaps you have a configuration problem?

Note, I am NO expert on this. It (vnc) pretty much has always “just worked” for me, so I have never learned the ‘ins and outs’ of it.

What I do is open 2 konsoles on my 10.3 PC. In the first konsole I type:

ssh -t -L 5900:localhost:5900 oldcpu@lan-ip-address-of-11-1-pc 'x11vnc -localhost -nolookup -nopw -display :0'

and enter my password when prompted.

Then on my 2nd terminal on my 10.3 PC I type:

vncviewer -encodings "tight copyrect hextile" localhost:0

and it simply works.

Other than explain what I do to make it work, I can’t offer any other advice/help.

When you enable Remote Administration in Yast what happens behind the scenes is that firewall ports 5901 and 5801 are opened and also xinetd is set to receive queries from a remote vncviewer and to enable the executable /usr/bin/Xvnc as appropriate. This is different from what oldcpu is talking about. He’s talking about the sister application x11vnc which runs on port 5900 and serves the already active :0 Xwindow.

Getting back to Xvnc → it doesn’t work in KDE4 in 11.1 but it does work in Gnome and KDE 3.5 in 11.1 I have reported the bug for KDE4. I am puzzled as to why it didn’t work for you in Gnome. You got no response at all for the Gnome effort which suggests the firewall port was closed. Check that.

Just a further note. I looked into the xinetd config to see if there were clues about Gnome. It says in the comment there that this function enables a KDM logon. So maybe the Remote Admin facility is not available in Gnome at all. Xvnc is of course available, but the “Remote Admin” setup might not be. I’ll look into it.

So @neiby: have you experiences with Remote Admin serving a Gnome desktop previously?

I haven’t used GNOME much at all. I just wanted to take a look at it and thought that was a good time to do it.

When I tried 11.0 earlier this week, all I had to do was go into Remote Administration and enable VNC. I also checked the box to automatically open up the firewall port.

I did exactly the same thing in 11.1 (KDE). I used Real VNC from my other desktop PC to access it. I got the login screen, but the entire screen would close after I entered my password and hit Enter.

When I tried this in GNOME, I got to the X server window, but the login screen did not display. I’ll check the firewall settings. It should have opened a port, but perhaps it didn’t.

I just verified that the firewall port is open, but I still don’t see the login screen using 11.1 GNOME. I at least got the login page with KDE.

For me in Gnome there is no Remote Administration option in Yast’s Network Services when using Gnome. That could be because the Remote Admin is really just a link that turns on VNC for KDM via Xinetd in Yast’s Network Services. Now if you haven’t got KDE installed then this cannot work (because the KDM login is the setup in xinetd).

So, probably, that variation on VNC won’t work in Gnome. I know that TightVNC will work in Gnome in openSUSE 11.1 and oldcpu has given another option with the x11vnc, so you can have VNC in gnome.

You cannot have Remote Admin when using KDE4 in openSUSE 11.1 because there’s a bug. But oldcpu has shown you an alternative until the bug is addressed. I reported it to Bugzilla only 10 days ago.

Yes in 10.3 I use to go in Yast/hardware/video and enable vnc…now it is no longer there.
Krfb dont’work well for me…
Hope a solution will come out soon

I wonder why you don’t have Remote Administration in 11.1 with GNOME? I just did a fresh installation of it from the LiveCD and it’s there. It doesn’t seem to work the same way it did in 11.0, but it’s there.

Earlier this evening I tested vnc (with the x11vnc/tightvnc commands I noted above) from KDE-4.1.3 (on openSUSE-11.1) taking over an openSUSE-10.3 desktop and it “just works”

Two minutes ago, I tested this the other way, by using vnc (via x11vnc/tightvnc) from my openSUSE 10.3, taking over a openSUSE-11.1 KDE-3.5.10. That “just works”.

However I was not able to go from openSUSE-10.3 taking over an openSUSE-11.1 KDE-4.1.3 session (with x11vnc/tightvnc). That does NOT work.

So using the command method I noted, there is a problem using openSUSE-11.1 KDE-4.1.3 as a server for vnc. The firewall has the correct ports open.

I wonder too. I wonder about quite a few things with VNC in 11.0 and 11.1lol!

I am using kde and I’m stocked with this remote admin.
Like I said in my previous post it was so nice and easy to enable it in yast-video card and monitor…
If this don’t get fixed I guess I’ll roll back to 10.3 even though it’s so nice 11.1 runs.
Nice Holydays and Happy Christmas

I am actually getting the same thing as the OP:

Opensuse 11.1

KDE: gets login screen but when login, remote connection closed (fixed by setting depth to 24 but still random crashes here and there)

Gnome: don’t even get login screen, some black and white pattern with an X cursor. However connection is established.

I enabled this in YAST remote admin and there is no firewall enabled.

Just out of interest have you tried without using a client but using a browser window…


whenever I cant connect using a vnc client normally tightvnc frow a windoz box… I use the web browser version.

I hope this helps…

Something that came up before make sure you are not using ip6 ???


Thanks for the tips – I had done those to no avail in my case. I have a bug report in on the problem, hopefully some action in the new year.

I’m waiting for Mr Claus to arrive so I’ll finish by saying: Merry Xmas to all

I tried the web method, http://server/5801

Got the login screen and then screen was replaced by

Network error: remote side closed connection
login again.


I have a suspicion that this is a permissions problem with x11 as setup for KDE4 on openSUSE (noting it works under KDE3). Unfortunately my knowledge in this is to weak to progress this, and I’m not particularly motivated (yet) as I plan to stay as a KDE3 user for well into next year.

24/12/2008 13:35:04 *** XOpenDisplay failed (:0)           

*** x11vnc was unable to open the X DISPLAY: ":0", it cannot continue.
*** There may be "Xlib:" error messages above with details about the failure 


** Next, you need to have sufficient permissions (Xauthority) 
   to connect to the X DISPLAY.   

I also note from this site: x11vnc: a VNC server for real X displays

To make sure X11 permissions are the problem do this simple test: while sitting at the physical X display open a terminal window (gnome-terminal, xterm, etc). You should be able to run x11vnc successfully without any need for special steps or command line options in that terminal (i.e. just type “x11vnc”). If that works OK then you know X11 permissions are the only thing preventing it from working when you try to start x11vnc via, say, a remote shell.
and indeed running x11vnc on physical X display on KDE4 does work.

Which suggests to me this is a KDE4 permissions issue. … However I could easily be wrong, as I do not know anything about this.

Further to this, I started x11vnc on PC #2 in our appartment, where PC#2 is running openSUSE-11.1 with KDE-4.1.3.

I then went to our family laptop (PC#1), running openSUSE-11.1 with KDE4.1.3, and I easily logged in via vnc with PC#2 taking over the desktop of PC#1 with vnc.

So vnc works on openSUSE-11.1 with KDE4 (but with a major bug), and I believe that supports my view that their is a permissions problem on openSUSE-11.1 KDE4/xorg such that one can not start vnc from a remote site (it has to be started locally). I do not know enough about this to localize this speculation of mine any further.

the OP is using KDM4 as his log in manager and that is were the problem is.

I get the crashes too, and had the same x screen as you.
I got around the xscreen by assigning a valid shell to the nobody account, nobody has /bin/false by default

usermod -s /bin/bash nobody

I have it figured out I think, and it seems to be working for me with Kde3, Kde4, and Gnome.

I kind of fell stupid because I spent a lot of time on this:P
I am connecting to my openSuse 11.1 box from my Windows XP box
I am using tight vnc viewer and Ultra vnc viewer
both connect with the default setting with only one change.
under options I clicked the little box for "let remote server deal with mouse cursor"
now everything is working with no crashes