VNC Black Screen Issue


I’m posting this here under Networks beings VNC stands for Virtual Network Connection and I don’t know where else to post it. It’s technically not Virtualization because virtualization implies that it is being run on one computer with another OS running on the same computer at the same time, and the OS I’m tapping into is on another computer.


I set my Dell Studio 540S up as a server type workstation. First time using it using ThinVNC worked like a charm. Second time, I got a blank screen that was black. I tried rebooting and nothing changed I tried deleting the .vnc directory and nothing. I tried just deleting the hosts file and restarting before recreating it, and nothing. I have to do all the directions below if it’s going to work. Ultra VNC produced the same issue. PuTTY just gives me a dinging noise after following the directions for VNC access I found online so I can’t even try that for VNC. To do the below, I usually log in through PuTTY SSH.

To fix the issue, I shut the vncserver down if it’s already running and entered the following commands:


(password entered here)

cat /etc/hosts > /Documents/hostsbackup

rm /etc/hosts

rm -r .vnc



(password entered here)

cat /Documents/hostsbackup > /etc/hosts (I created a backup - see below for information on that)


I then create my password again.

If I do not follow this process to a T, the VNC Server does not give anything but a blank (black) screen. A simple reboot does not do the trick. Just deleting the .vnc file does not do the trick. And I checked, the hosts file does not change in the slightest but the only way to get it to work is to delete the hosts file, delete the .vnc directory, reboot, recreate the hosts file, and start the vncserver.

The hosts file has the contents of:     localhost (This is actually changed to my host name - leaving it as localhost generates a bad host name error)
   ::1              localhost ip6-localhost ip6-loopback
   fe00::0        ip6-localnet
   ff00::0         ip6-mcastprefix
   ff02::1         ip6-allnodes
   ff02::2         ip6-allrouters

It also does not matter if I try to tap in through my home network or if I’m out and about and try to connect from my mom’s network (and each location is a different log-in as far as what I enter for the computer’s address).

Is there anything I can do to not have to go through this process each time? I set this Dell up for a media center to play DVDs and watch Netflix but also to store things like Photos and such to free up cloud space and be able to access my stuff anywhere there is an internet connection for my laptops.

In the meantime, I’m going to set up a few scripts to automate this for the most part… but it would be greatly appreciated if someone could tell me how to fix this permanently instead of this temp fix I figured out.

VNC server probably works differently today compared to how you may have used in the past.

Read the openSUSE community docs on this subject

And, in particular, note how VNC Server configurations are made in the file described in this section, not elsewhere and not on the command line

If you understand the above,
Then it should become clear that the VNC client should then pass only the address and port, and optionally a username/password… nothing else ever because everything additional is controlled on the Server side.


I fixed it. I reverted Tumbleweed to Leap 42.2 and the issue (and a few others) resolved themselves oddly enough. I reverted back to leap because I suspected a driver I needed (a legacy driver for a broadcom 4321 wireless card) was not compatible because it kept erroring on install and not working. In the process, it resolved several issues I was having, including the vncserver issue.