VNC black screen after recent updates

Hi,

I had VNC working previously but after some recent updates ( I think, because I didn't change any of my configurations ) it no longer works properly.  At first I was getting weird "bad display" errors when starting VNC but I was able to resolve those by putting my hostname into the /etc/hosts file.  Now I can start VNC just fine, but when I connect to it, it is just a black screen with a mouse cursor and I can't do anything.  Searching around and poking through some log files I came across this in my ~/.vnc/linux-22fd\:2.log file:

Xvnc TigerVNC 1.7.1 - built ??? ?? ???? ??:??:??
Copyright (C) 1999-2016 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 11901000, The X.Org Foundation


Thu Feb  2 06:46:34 2017
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5902
 vncext:      Listening for HTTP connections on all interface(s), port 5802
 vncext:      created VNC server for screen 0
Loading stage  "initial" 139
startkde: Starting up...
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.InvalidArgs: Invalid environment assignments
Waiting for already running klauncher to exit.
Waiting for already running klauncher to exit.
Another instance of klauncher is already running!
kdeinit5: Communication error with launcher. Exiting!

kdeinit5_wrapper: Warning: connect(/run/user/1000/kdeinit5__2) failed: : Connection refused
Qt: Session management error: networkIdsList argument is NULL
Configuring Lock Action
XSync seems available and ready
XSync Inited
Supported, init completed
Created alarm 8388609
ksmserver: "/run/user/1000/KSMserver"
ksmserver: KSMServer: SetAProc_loc: conn  0 , prot= local , file= @/tmp/.ICE-unix/8954
ksmserver: KSMServer: SetAProc_loc: conn  1 , prot= unix , file= /tmp/.ICE-unix/8954
ksmserver: KSMServer::restoreSession  "saved at previous logout"
startkde: Shutting down...
kdeinit5_wrapper: Warning: connect(/run/user/1000/kdeinit5__2) failed: : Connection refused
Error: Can not contact kdeinit5!
startkde: Done.
Qt: Session management error: Could not open network socket

Thu Feb  2 06:46:58 2017
 Connections: accepted: 192.168.1.3::56923
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)
 SVeNCrypt:   Client requests security type TLSVnc (258)

Thu Feb  2 06:47:01 2017
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 24 (32bpp) little-endian rgb888

Thu Feb  2 06:47:16 2017
 Connections: closed: 192.168.1.3::56923 (Clean disconnection)
 EncodeManager: Framebuffer updates: 3
 EncodeManager:   Tight:
 EncodeManager:     Solid: 4 rects, 8.676 Mpixels
 EncodeManager:            64 B (1:542251 ratio)
 EncodeManager:   Total: 4 rects, 8.676 Mpixels
 EncodeManager:          64 B (1:542251 ratio)
~

So it looks like some sort of dbus/systemd error when starting KDE? Or if that warning error can be ignored the problem would be with kdeinit5. But I’m not quite sure what to do next with this error message. Googling for that sort of error message and searching the forums hasn’t brought up anything recent or seemingly relevant to my specific problem. If not using VNC, (e.g. starting via normal direct connect monitor/keyboard ) KDE works fine so it appears to be unique to starting VNC with KDE. I did see one suggestion that SDDM shouldn’t be used with VNC/KDE combo, but unless the display manager was just changed, it has been working fine with SDDM up until now, so I have not tried changing that.
Any ideas on what is wrong or how to keep debugging this?

Thanks in advance.

Hi,

I managed to fix this problem using the novell/micro focus VNC troubleshoot.
https://www.novell.com/support/kb/doc.php?id=7010062

it seems no matter what gui you have installed displaymanager will always defaulted to gnome. so if gnome is not installed then no gui when you VNC. (that was my case). the solution is to edit the displaymanger below and change gdm to the gui you wish to use. and restart the service. (in my case I changed it to kdm).

Now its woking VNCing to a kdm gui no problem. :slight_smile:

I hope this helps others.

Purpleroccket09

Displaymanager
Using your favourite editor open the following file:

/etc/sysconfig/displaymanager

In this file look for the following entries:

DISPLAYMANAGER=“gdm”
DISPLAYMANAGER_REMOTE_ACCESS=“yes”
DISPLAYMANAGER_ROOT_LOGIN_REMOTE=“yes”

The “DISPLAYMANAGER=” setting will normally be set to either gdm (for GNOME) or kdm4 (for KDE4). GNOME/gdm is the default unless KDE4 was specifically selected as the desktop during installation. This is important to know so that the appropriate instructions can be followed in the section below for either gdm or kdm4.

…same mess here after the last two kernel updates, vnc serving a black screen with cursor. But for me a reboot resolved it without messing around with any config…